summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-29 07:07:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-29 07:51:20 +0200
commit3130fca7fb19d2d0e9fed2c30822cf1f2d1aceee (patch)
treea465986fc5c66b21ad6da06307f3885a53c220fb
parentnet-im/telegram-desktop-bin: bump version to 2.8.10 (diff)
downloadgentoo-3130fca7.tar.gz
gentoo-3130fca7.tar.bz2
gentoo-3130fca7.zip
dev-python/importlib_resources: Bump to 5.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.2.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index 365a5340202b..88d1250b2c33 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,2 +1,3 @@
DIST importlib_resources-5.1.4.tar.gz 28783 BLAKE2B e88cbe34dfd9b251fc78f2aba173f3eb657462777cb66454fbc1735575c6cac6a868f5e40206fb8925aa8c7f708d72624693cd772f2335231bc5da4f417d622e SHA512 ede757b0ee4a246a3446a165f4c8e56edf326f90464f01d853b6c04042371ff1edc4e41f388c6ea6973302a183cf1c04ee21335342886747c991ba0b38c7aec3
DIST importlib_resources-5.2.0.tar.gz 29655 BLAKE2B 570e92750351a72c95653302baee56dadc28a328a8e42af9d3346be9a256c2d43322d75622f78d87b5642ed9503c9b7f1df0b0223414847619efb2ebd5e27f5f SHA512 248de71aec8aae93f14b0c48381e7de4425f1eb0c014a4f4a49859db50e8b0a94c2e1c0a664086c74ac7fe19e526b8e3f4fc82d19d3d722df6625dc0dc708c90
+DIST importlib_resources-5.2.1.tar.gz 29622 BLAKE2B 3ac095355534c1ea35e65d685e36ea715555dbda686e1312851b0ea5ce079053429812da5ba57b00bf02981786037de2c5e91a4bc0eedf03c8463f184180c10b SHA512 e0534c6e0e1cfe8621710e58f43b0ec3e5a6fd9e1eafa58ffa09f9120e05a416b69b45639f3028f7d4d02831429bc5de3cbfa97e141474d268d6c32a5f14c1bd
diff --git a/dev-python/importlib_resources/importlib_resources-5.2.1.ebuild b/dev-python/importlib_resources/importlib_resources-5.2.1.ebuild
new file mode 100644
index 000000000000..e844671db232
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-5.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# This is a backport of Python 3.9's importlib.resources
+PYTHON_COMPAT=( pypy3 python3_8 )
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://github.com/python/importlib_resources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/zipp-3.1.0[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging