summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-13 19:17:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-13 19:31:27 +0300
commit3151ab226751d27146d2febbf76e22d1d6ebe2ee (patch)
treedca25b6d1b5b73917c60f546eb6e75d3c0a7a4a4
parentdev-python/jaraco-packaging: enable py3.11 (diff)
downloadgentoo-3151ab226751d27146d2febbf76e22d1d6ebe2ee.tar.gz
gentoo-3151ab226751d27146d2febbf76e22d1d6ebe2ee.tar.bz2
gentoo-3151ab226751d27146d2febbf76e22d1d6ebe2ee.zip
dev-python/jaraco-stream: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-3.0.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jaraco-stream/jaraco-stream-3.0.3-r1.ebuild b/dev-python/jaraco-stream/jaraco-stream-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..601d78e3abe3
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-3.0.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest