summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 00:43:46 +0000
committerSam James <sam@gentoo.org>2020-10-17 01:01:29 +0000
commit3153572fb621a666c0c9fc109e8fcadfc9e47015 (patch)
tree77aa8258d77e1ff027c528190055c3f2b6ff5ed8
parentwww-client/opera-beta: Version 72.0.3815.133 (diff)
downloadgentoo-3153572fb621a666c0c9fc109e8fcadfc9e47015.tar.gz
gentoo-3153572fb621a666c0c9fc109e8fcadfc9e47015.tar.bz2
gentoo-3153572fb621a666c0c9fc109e8fcadfc9e47015.zip
dev-ml/camomile: bump to 1.0.2 (fix >=4.10.0 compat)
Closes: https://bugs.gentoo.org/749149 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/camomile/Manifest1
-rw-r--r--dev-ml/camomile/camomile-1.0.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/camomile/Manifest b/dev-ml/camomile/Manifest
index 23be6ef1a841..1c3860b2bb5d 100644
--- a/dev-ml/camomile/Manifest
+++ b/dev-ml/camomile/Manifest
@@ -1 +1,2 @@
DIST camomile-0.8.5.tar.bz2 2607084 BLAKE2B 5e0ff51cdd6d7ce41ee024189a793f3d3e4bec1bd9849e7c01d2722ff22ca2cb5f0d5bd5f95820e741469ebda2996edf3611827535df5fe095d3f6617ecfdd42 SHA512 ef4da32f955e69e0b2958b4b2bf12ae94e210d8aa7cee5a9030607b79ac43a884758549f3164c223fb07d987a4a50b15f0bc5083ff67120270409f7fb9928014
+DIST camomile-1.0.2.tar.gz 7032339 BLAKE2B 8cd60c74821c2c8e7084e752d1e4d67428c935859e02a8630f3f5563b53b3ce444071fa26153950f6a410b2743073692c7061e4f1f902c23e5fa54c50a89383c SHA512 d62ecaa297058b52674f98e513a6d776148fe62651b2b4a2dac4bb3e05abb8b7684960e889f68c6dab60aee669fbab715a2d6a9206645e24d10d8aaaf7cedf0e
diff --git a/dev-ml/camomile/camomile-1.0.2.ebuild b/dev-ml/camomile/camomile-1.0.2.ebuild
new file mode 100644
index 000000000000..56a31353629c
--- /dev/null
+++ b/dev-ml/camomile/camomile-1.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
+HOMEPAGE="https://github.com/yoriyuki/Camomile/wiki"
+SRC_URI="https://github.com/yoriyuki/Camomile/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+
+# Unbound module errors
+RESTRICT="test"
+
+src_compile() {
+ # Amend standard dune_src_compile with -p camomile
+ # Needed to workaround: https://github.com/yoriyuki/Camomile/issues/83
+ # (https://dune.readthedocs.io/en/stable/faq.html#how-to-make-warnings-non-fatal)
+ dune build -p camomile @install || die
+}