summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-10-31 19:20:57 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-10-31 19:20:57 -0500
commit3160d935ef2cc7c2004fde675b3ba6420041c744 (patch)
tree23f947a12f20696a041f5337e5cf47ad3f186e02
parentdev-python/botocore: add version 1.3.2 (diff)
downloadgentoo-3160d935ef2cc7c2004fde675b3ba6420041c744.tar.gz
gentoo-3160d935ef2cc7c2004fde675b3ba6420041c744.tar.bz2
gentoo-3160d935ef2cc7c2004fde675b3ba6420041c744.zip
dev-python/stormpath: add version 2.1.2
Package-Manager: portage-2.2.23
-rw-r--r--dev-python/stormpath/Manifest1
-rw-r--r--dev-python/stormpath/stormpath-2.1.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/stormpath/Manifest b/dev-python/stormpath/Manifest
index 25c04ea78742..79f9ba099429 100644
--- a/dev-python/stormpath/Manifest
+++ b/dev-python/stormpath/Manifest
@@ -1,3 +1,4 @@
DIST stormpath-2.0.8.tar.gz 4326469 SHA256 9f6ad7e7b210024915e2139b2ed395a7c0fff6ca49ad3cdf58dc8f214d080c70 SHA512 661714fac02528111bb01e30f8c16b1d8701fe894b21d803958331819ce145a9ec03864111b861286224b33aaf56ca68ddcef2b67cd0003c498cd007ce375a03 WHIRLPOOL 12e6f7ec559a654ab59d34106d85d98ada4c7e3dee6fcec6cad0a2500608e962289d73a50e6ce6d81122c43f0f53b30d861203c8a976ac7bdbdab1cd8f5db6be
DIST stormpath-2.0.9.tar.gz 4325976 SHA256 ba93f1f9f6b98db2eb2671d2b3285fdd15f8b2e6d3bce899f240576018f216ae SHA512 b50fa11e8fecf4909a8a1014963c80e7e2dde4db37e1f4681c2a116933d59f5b5ea32901cfde97b24398d8074db8b04121b2a7715d86b6b2eb78eb288465114c WHIRLPOOL 6290d5844d35158cc46f1810b6f83e41c443164cff4512caeeb38e562b04f448c1ac1b608b2cda4abd348f91319e4e8fbb3b195ba31a8fb415ba80f0ed7c5937
DIST stormpath-2.1.1.tar.gz 4326557 SHA256 94600e8368f2fbe06adea5fddc8f4b7a479f7a89a0a35a46f58f7c796286e5f4 SHA512 7548aff63e5f04718d4d4887a1177f6f0cf3cc8cb9588e17f7563bae9c6dc5897a968ee2c4e189b6d9100ef16ec7e34e524c4cd3c5112845c0619876ca6d5505 WHIRLPOOL 33db1d8e52d24581a1fe7220b4329479142772939d1df76d52a46d47db6219890fde3204655dd65851d43b38e2427cd32df894392948482d85554772b9f12bbf
+DIST stormpath-2.1.2.tar.gz 4337164 SHA256 10f46c7ebb27274f61c4b550eb6fc58e54260fa0fb1f96a4b7fce530d789d11c SHA512 c3b3e93f4d5515df8e5ab94770c995a5e7912a53f58f05ca3a1f630c41fc0f76e39cf213dbfad8858d7bfe5f964f6d9cbfad9013de33e9a02e0484bd92a7957d WHIRLPOOL adfbf1cf071167a93989cd4d80039a4eb8c42a908075207a4db4db3a38c87e3b9470b9c1c02946e9481e52d875e836d0c77a72050de2a1f79fc78b5ed037dfe2
diff --git a/dev-python/stormpath/stormpath-2.1.2.ebuild b/dev-python/stormpath/stormpath-2.1.2.ebuild
new file mode 100644
index 000000000000..e6bdfe5b1541
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}