summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-10-28 15:38:54 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-28 15:38:54 +0200
commit3173fd510f98c7c672d4a3149bcf265036ce7fd3 (patch)
tree43d6018680a47def1b9835afeca854eccb8ba8b9
parentdev-lang/php: Version bump for 7.3.32 (diff)
downloadgentoo-3173fd510f98c7c672d4a3149bcf265036ce7fd3.tar.gz
gentoo-3173fd510f98c7c672d4a3149bcf265036ce7fd3.tar.bz2
gentoo-3173fd510f98c7c672d4a3149bcf265036ce7fd3.zip
app-editors/sublime-text: add 4_p4121
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-editors/sublime-text/Manifest1
-rw-r--r--app-editors/sublime-text/sublime-text-4_p4121.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-editors/sublime-text/Manifest b/app-editors/sublime-text/Manifest
index 3dde261a7062..8e11985d45e2 100644
--- a/app-editors/sublime-text/Manifest
+++ b/app-editors/sublime-text/Manifest
@@ -2,3 +2,4 @@ DIST sublime_text_3_build_3211_x32.tar.bz2 13806489 BLAKE2B 1e07df2fc9fb9fb60a6f
DIST sublime_text_3_build_3211_x64.tar.bz2 13677324 BLAKE2B e2ac54c1e8ab90c0fcefb4baf225b02d13a3405e846f08163773ed52c6278f8e89a7b13c15e6c2d6241139d58be9c2c5a1201abb04a3cd68efdffc723075c5af SHA512 a6a068119eff95c5360e9ccbe1d845e7a93e4ad13b3659073752a7bd0e87f4691555820185514875649e677a4e8702e2338f74f5584fc80f69c16b323685d6f1
DIST sublime_text_build_4107_x64.tar.xz 17096632 BLAKE2B 37c1839ef1edecb1f3017e4d99d2b8b0bf5c0aa1490495fe19a48cf38bb436e94913572a4dd5ad5f84e6b5445b6a9a2df35fec607beb0b520471b2dde7ef63fd SHA512 552051b34c612aa6ff53ef6275488467061221715de054dc1e657519c82899e24df1a9f8000086b68c5c1c6e0c98341c641f19a2d97c880efb25aa93ad82f8aa
DIST sublime_text_build_4113_x64.tar.xz 17105200 BLAKE2B 6a23e9eb7ec5b7b5dfef2ef496e0b7fcf053be3349c8318e85373bc9c3d4d69da3e4e94971ae83832aa254c175a58062a33ffb14d2103c1cdb6888c1223f28ed SHA512 f0e5e8e28754c21bf5c9fc3e50502d22d72fec4819c68d8444cb341aa7ee4d6bc43edfda594fba3c446c2b252bd7a65340dd7a407d81f875971c219bb2236479
+DIST sublime_text_build_4121_x64.tar.xz 17181776 BLAKE2B a8404a15af67934ba5c2c038d2259e454a505592f53007f665a596554dd13e5c09729577520052290df7bf393ddbcb33321d1624679c4af3bcf5a07ac038f6a5 SHA512 809ef4acabe1e52918b2e7c6057623380b1c7ba5bf0298aa59ec06b49d258fe37fd7177a79bdc840cbc4228a7944cfa67847c3bf3b1b26b3c171815f80c59103
diff --git a/app-editors/sublime-text/sublime-text-4_p4121.ebuild b/app-editors/sublime-text/sublime-text-4_p4121.ebuild
new file mode 100644
index 000000000000..67a825bdb8e4
--- /dev/null
+++ b/app-editors/sublime-text/sublime-text-4_p4121.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop wrapper xdg
+
+# get the major version from PV
+MY_PV=$(ver_cut 3)
+MY_PN=${PN/-/_}
+
+DESCRIPTION="Sophisticated text editor for code, markup and prose"
+HOMEPAGE="https://www.sublimetext.com"
+SRC_URI="
+ amd64? ( https://download.sublimetext.com/sublime_text_build_${MY_PV}_x64.tar.xz )"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="Sublime"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dbus"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ dbus? ( sys-apps/dbus )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4_p4107-remove-deprecated-key-onlyshowin-from-launcher.patch
+ "${FILESDIR}"/${PN}-4_p4107-set-explicit-startupwmclass-in-launcher.patch
+)
+
+QA_PREBUILT="*"
+
+# Sublime bundles the kitchen sink, which includes python and other assorted
+# modules. Do not try to unbundle these because you are guaranteed to fail.
+
+src_install() {
+ insinto /opt/${MY_PN}
+ doins -r Packages Lib Icon # /Icon is used at runtime by the application
+ doins changelog.txt libcrypto.so.1.1 libssl.so.1.1 sublime_text.desktop
+
+ # sublime_merge looks for /opt/sublime_text/sublime_text
+ exeinto /opt/${MY_PN}
+ doexe crash_reporter plugin_host-3.3 plugin_host-3.8 sublime_text
+
+ # sublime-text sets its WM_CLASS based on its argv[0]. A wrapper script is
+ # used instead of a symlink to preserve a consistent WM_CLASS regardless of
+ # how the application is launched. This causes the WM_CLASS to be
+ # "sublime_text" which matches the .desktop entry.
+ make_wrapper subl "/opt/${MY_PN}/sublime_text --fwdargv0 \"\$0\""
+ domenu sublime_text.desktop
+
+ local size
+ for size in 16 32 48 128 256; do
+ doicon --size ${size} Icon/${size}x${size}/${PN}.png
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog 'Sublime Text 4'"'"'s window class changes from WM_CLASS="subl" to'
+ elog 'WM_CLASS="sublime_text" matching other distributions.'
+}