summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-24 18:18:47 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-26 21:06:10 +0300
commit31924c07f3aedf1c491da6de90ab99b776760107 (patch)
tree4476867a8a4b0749a5b29fa2308557dcb2b77484
parentnet-libs/libquotient: drop 0.8.1.1-r1 (diff)
downloadgentoo-31924c07f3aedf1c491da6de90ab99b776760107.tar.gz
gentoo-31924c07f3aedf1c491da6de90ab99b776760107.tar.bz2
gentoo-31924c07f3aedf1c491da6de90ab99b776760107.zip
media-sound/mpfc: EAPI8 bump, use https
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/33037 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--media-sound/mpfc/mpfc-1.3.8.1-r5.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-sound/mpfc/mpfc-1.3.8.1-r5.ebuild b/media-sound/mpfc/mpfc-1.3.8.1-r5.ebuild
new file mode 100644
index 000000000000..f182195b0023
--- /dev/null
+++ b/media-sound/mpfc/mpfc-1.3.8.1-r5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Music Player For Console"
+HOMEPAGE="https://mpfc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa cdda flac gpm mad nls oss static-libs vorbis wav"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
+ flac? ( media-libs/flac:= )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ mad? ( media-libs/libmad )
+ vorbis? ( media-libs/libvorbis )
+ sys-libs/ncurses:=[unicode(+)]
+ dev-libs/icu:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-underlinking.patch"
+ "${FILESDIR}/${P}-qa-implicit-declarations.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable alsa)
+ $(use_enable cdda audiocd)
+ $(use_enable flac)
+ $(use_enable gpm)
+ $(use_enable mad mp3)
+ $(use_enable nls)
+ $(use_enable oss)
+ $(use_enable static-libs static)
+ $(use_enable vorbis ogg)
+ $(use_enable wav)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins mpfcrc
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}