summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-30 12:31:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-30 17:20:26 +0200
commit31aa7b44d592caeec02e464d1a958eb6c704759a (patch)
treed5801d9dca558a68f856413f37ad9c22fd89b9b7
parentmedia-sound/aqualung/files: Add missing patches (diff)
downloadgentoo-31aa7b44d592caeec02e464d1a958eb6c704759a.tar.gz
gentoo-31aa7b44d592caeec02e464d1a958eb6c704759a.tar.bz2
gentoo-31aa7b44d592caeec02e464d1a958eb6c704759a.zip
dev-python/gssapi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gssapi/Manifest1
-rw-r--r--dev-python/gssapi/gssapi-1.8.2-r1.ebuild48
-rw-r--r--dev-python/gssapi/gssapi-1.8.3.ebuild48
3 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/gssapi/Manifest b/dev-python/gssapi/Manifest
index 9bca8b556b54..c3e1194be67c 100644
--- a/dev-python/gssapi/Manifest
+++ b/dev-python/gssapi/Manifest
@@ -1,2 +1 @@
-DIST gssapi-1.8.2.gh.tar.gz 112521 BLAKE2B d7e14c73c346066a58ae3b3cf1faeec2ef7df3d4da3f2c9e3198928225d81d99466185a9dfa06a59ae50beeeed58d4e73f8a668e1ac605e5b9806ed7a0019831 SHA512 6587f1947dc396bf608ba71e77388e6f7d161753005b9b82ea9f3b174c898bb18409a27e9aa035fc782e15fcd2efe7ca5c497d4687d69023034cea59d6a003df
DIST gssapi-1.8.3.gh.tar.gz 113958 BLAKE2B e830ae4ee0f22ef85c4ae193cb62ad3ebec222cd4ea9c9b9531b621b358bc71a9e46440ed673f888837a5d42746a6c9d4033fed1db5f1dc044e982cd5d63e3d8 SHA512 f08a318beac4b2807f33f5c30ccdafeafed0971537456a477138fe783f7fd9f05ab59cff74030c3041504302b0922307e5c391cd5d0e8b4f370f0036a5ef45b8
diff --git a/dev-python/gssapi/gssapi-1.8.2-r1.ebuild b/dev-python/gssapi/gssapi-1.8.2-r1.ebuild
deleted file mode 100644
index b1ac1962c5ed..000000000000
--- a/dev-python/gssapi/gssapi-1.8.2-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Low and high level wrappers around the GSSAPI C libraries"
-HOMEPAGE="
- https://github.com/pythongssapi/python-gssapi/
- https://pypi.org/project/gssapi/
-"
-SRC_URI="
- https://github.com/pythongssapi/python-gssapi/releases/download/v${PV}/python-${P}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}"/python-${P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- virtual/krb5
-"
-
-# cython-3 produces a broken extension still
-# https://github.com/pythongssapi/python-gssapi/issues/327
-BDEPEND="
- <dev-python/cython-3[${PYTHON_USEDEP}]
- virtual/krb5
- test? (
- dev-python/k5test[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- cd "${T}" || die
- epytest --pyargs gssapi
-}
diff --git a/dev-python/gssapi/gssapi-1.8.3.ebuild b/dev-python/gssapi/gssapi-1.8.3.ebuild
deleted file mode 100644
index 3c31abe7865b..000000000000
--- a/dev-python/gssapi/gssapi-1.8.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Low and high level wrappers around the GSSAPI C libraries"
-HOMEPAGE="
- https://github.com/pythongssapi/python-gssapi/
- https://pypi.org/project/gssapi/
-"
-SRC_URI="
- https://github.com/pythongssapi/python-gssapi/releases/download/v${PV}/python-${P}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}"/python-${P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-RDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- virtual/krb5
-"
-
-# cython-3 produces a broken extension still
-# https://github.com/pythongssapi/python-gssapi/issues/327
-BDEPEND="
- <dev-python/cython-3[${PYTHON_USEDEP}]
- virtual/krb5
- test? (
- dev-python/k5test[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- cd "${T}" || die
- epytest --pyargs gssapi
-}