summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-17 19:44:06 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-17 20:02:11 +0200
commit31b0f10be985e48e355706f55fb3c580dddb465d (patch)
tree0cc37ad97af5fe89721d2f6d01e797fd603eefbd
parentnet-wireless/soapyuhd: bump (diff)
downloadgentoo-31b0f10b.tar.gz
gentoo-31b0f10b.tar.bz2
gentoo-31b0f10b.zip
dev-python/josepy: bump to 1.4.0, add tests and Py3.9+PyPy3 support
Also: * Fix deps. * Remove blocker on acme 0.20.0 (removed from the tree more than 2 years ago). * Update HOMEPAGE. * EAPI=7. Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/josepy/Manifest1
-rw-r--r--dev-python/josepy/josepy-1.4.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/josepy/Manifest b/dev-python/josepy/Manifest
index 117aeda6b739..c1ba4f7f0578 100644
--- a/dev-python/josepy/Manifest
+++ b/dev-python/josepy/Manifest
@@ -1 +1,2 @@
DIST josepy-1.3.0.tar.gz 53279 BLAKE2B 7dbbdd97491d4fab7a6f086c47458e2e34908ee4377e30138a64a42b81396cba72dc0f8483d21f4f7499715eb49f9503cc12b08cdc270d4cd6fcc05a6888dc8f SHA512 176eea34bb7fb75e192d6792c15581a42a1d2b986bc79ab49f72b16ebf8879e9b11db0d22fbd49ff5a9b85ab7cc45a0a935d06393273233a272537a861282f30
+DIST josepy-1.4.0.tar.gz 54174 BLAKE2B 67117e7399422d0cfe2c47f9e5ed11a3b93617e673cf9ab1344334f7f11f0c884f45202e8e5e65ebacc00f527becfdbdda9ea246b8e96ba15e516bfc2fb33ba9 SHA512 a5038a4bb42c5a55d665a551743a976b209c24d8aa368d2b6acf0957e953bd4044d9dc41bf9d460283f44c14b7dd7ce2a860563fe107663d4a4deba0c7834e40
diff --git a/dev-python/josepy/josepy-1.4.0.ebuild b/dev-python/josepy/josepy-1.4.0.ebuild
new file mode 100644
index 000000000000..5acbb31edeab
--- /dev/null
+++ b/dev-python/josepy/josepy-1.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="JOSE protocol implementation in Python"
+HOMEPAGE="https://github.com/certbot/josepy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove coverage/flake8 options
+ sed -i '/^addopts =/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}