summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-05 00:07:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-05 00:56:16 +0200
commit31d55ce00ac3df59f818998a0482032201b7f6a6 (patch)
treecf9432b1b7a16f3b56abfb8ff2798df44282fc72
parentsys-process/at: Stabilize 3.2.2-r1 amd64, #787797 (diff)
downloadgentoo-31d55ce00ac3df59f818998a0482032201b7f6a6.tar.gz
gentoo-31d55ce00ac3df59f818998a0482032201b7f6a6.tar.bz2
gentoo-31d55ce00ac3df59f818998a0482032201b7f6a6.zip
dev-python/pyicu: Bump to 2.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.7.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index 19f758dfa91a..a92a6ff011f6 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1,2 +1,3 @@
DIST PyICU-2.6.tar.gz 233826 BLAKE2B 318b87b878f8d49f47f48780567751671f5f88902c4cae9a243a81300b002ca6ea2336aee38bfc76a3037326f15f197fd71819173b678c68094d16f8db51864e SHA512 ab4c167cbeb80a23904476e51a3c16aa4721e26840b1d4c2f44b5a610e5467a6880c45f27636efb9e44e8e4302a095d437f4868409103270d79ecd56a3d90c9c
DIST pyicu-v2.7.2.tar.bz2 238645 BLAKE2B cca24a2cda18e943ac00a50b9a28342845af156b66bffcae2ec915e8e5d97577e1c5975b6711051558223278ccd7ad33782d02e759427ace4ce609fcad1c7ba6 SHA512 ece8a7a7e5162de8a2ad7a1ae1310ca4f32c6d27695942580a9a4cd1755a94c4230fe9f9e1c9a6b5a7d4a712b2ad570660e89316f437a7af502521e91137960e
+DIST pyicu-v2.7.3.tar.bz2 239703 BLAKE2B ce575c313d0e24838f87d270afce70e8b702753ec41d188bcdd60492f97ea276bca194c1bfd6224de17eaf84455509079e007b81e58c09ad0f48340b231e8671 SHA512 ff3bfdc5f24f259dc470f44c65707f7c29bff5c56dc85be7d4551269e5b6cc6e8f3a6953c5faae63aa9eb62e55f6ac75b32a1524f80ce2a7661de56ee1a5bf99
diff --git a/dev-python/pyicu/pyicu-2.7.3.ebuild b/dev-python/pyicu/pyicu-2.7.3.ebuild
new file mode 100644
index 000000000000..98aecea4d8c8
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/icu:="
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest