summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-31 03:00:17 +0100
committerSam James <sam@gentoo.org>2022-08-31 03:00:46 +0100
commit31d9717391661df9bfc70bd4fb1902730961f115 (patch)
tree5d5281095a1c8ddea70917e1065b970a17ef53a6
parentdev-libs/keystone: build system requires python during build time (diff)
downloadgentoo-31d97173.tar.gz
gentoo-31d97173.tar.bz2
gentoo-31d97173.zip
media-libs/libsdl2: backport CMake config file fixes
Fixes build of consumers/reverse dependencies using CMake to discover SDL2. devilutionx failed like: ``` -- Configuring done CMake Error at CMakeLists.txt:243 (target_link_libraries): Target "devilutionx" links to: SDL2::SDL2main but the target was not found. Possible reasons include: * There is a typo in the target name. * A find_package call is missing for an IMPORTED target. * An ALIAS target is missing. ``` See https://forums.gentoo.org/viewtopic-p-8741497.html. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/libsdl2/files/libsdl2-2.24.0-cmake-target-fixes.patch145
-rw-r--r--media-libs/libsdl2/libsdl2-2.24.0-r1.ebuild228
2 files changed, 373 insertions, 0 deletions
diff --git a/media-libs/libsdl2/files/libsdl2-2.24.0-cmake-target-fixes.patch b/media-libs/libsdl2/files/libsdl2-2.24.0-cmake-target-fixes.patch
new file mode 100644
index 000000000000..59353b98e06d
--- /dev/null
+++ b/media-libs/libsdl2/files/libsdl2-2.24.0-cmake-target-fixes.patch
@@ -0,0 +1,145 @@
+https://github.com/libsdl-org/SDL/commit/329794daf3f58088b56a64bdfa36b2021903be20
+https://github.com/libsdl-org/SDL/commit/62302d08f13ca5303135505c6b355afbbf069745
+
+From: Anonymous Maarten <anonymous.maarten@gmail.com>
+Date: Sun, 21 Aug 2022 04:03:32 +0200
+Subject: [PATCH] cmake: add library directories & pthread to imported targets
+ of sdl2-config.cmake
+
+This fixes linking to SDL2::SDL2-static on systems where external libraries such as X11 are not in a standard location.
+Pthread also needs special care.
+--- a/sdl2-config.cmake.in
++++ b/sdl2-config.cmake.in
+@@ -39,18 +39,25 @@ unset(bindir)
+ unset(libdir)
+ unset(includedir)
+
+-set(_sdl2_libraries "@SDL_LIBS@")
+-set(_sdl2_static_private_libs "@SDL_STATIC_LIBS@")
++set(_sdl2_libraries_in "@SDL_LIBS@")
++set(_sdl2_static_private_libs_in "@SDL_STATIC_LIBS@")
+
+-# Convert _sdl2_libraries to list and keep only libraries
+-string(REGEX MATCHALL "-[lm]([-a-zA-Z0-9._]+)" _sdl2_libraries "${_sdl2_libraries}")
++# Convert _sdl2_libraries to list and keep only libraries + library directories
++string(REGEX MATCHALL "-[lm]([-a-zA-Z0-9._]+)" _sdl2_libraries "${_sdl2_libraries_in}")
+ string(REGEX REPLACE "^-l" "" _sdl2_libraries "${_sdl2_libraries}")
+ string(REGEX REPLACE ";-l" ";" _sdl2_libraries "${_sdl2_libraries}")
++string(REGEX MATCHALL "-L([-a-zA-Z0-9._/]+)" _sdl2_libdirs "${_sdl2_libraries_in}")
++string(REGEX REPLACE "^-L" "" _sdl2_libdirs "${_sdl2_libdirs}")
++string(REGEX REPLACE ";-L" ";" _sdl2_libdirs "${_sdl2_libdirs}")
++list(APPEND _sdl2_libdirs "${SDL2_LIBDIR}")
+
+-# Convert _sdl2_static_private_libs to list and keep only libraries
+-string(REGEX MATCHALL "(-[lm]([-a-zA-Z0-9._]+))|(-Wl,[^ ]*framework[^ ]*)" _sdl2_static_private_libs "${_sdl2_static_private_libs}")
++# Convert _sdl2_static_private_libs to list and keep only libraries + library directories
++string(REGEX MATCHALL "(-[lm]([-a-zA-Z0-9._]+))|(-Wl,[^ ]*framework[^ ]*)|(-pthread)" _sdl2_static_private_libs "${_sdl2_static_private_libs_in}")
+ string(REGEX REPLACE "^-l" "" _sdl2_static_private_libs "${_sdl2_static_private_libs}")
+ string(REGEX REPLACE ";-l" ";" _sdl2_static_private_libs "${_sdl2_static_private_libs}")
++string(REGEX MATCHALL "-L([-a-zA-Z0-9._/]+)" _sdl2_static_private_libdirs "${_sdl2_static_private_libs_in}")
++string(REGEX REPLACE "^-L" "" _sdl2_static_private_libdirs "${_sdl2_static_private_libdirs}")
++string(REGEX REPLACE ";-L" ";" _sdl2_static_private_libdirs "${_sdl2_static_private_libdirs}")
+
+ if(_sdl2_libraries MATCHES ".*SDL2main.*")
+ list(INSERT SDL2_LIBRARIES 0 SDL2::SDL2main)
+@@ -103,6 +110,7 @@ if(WIN32)
+ set_target_properties(SDL2::SDL2 PROPERTIES
+ INTERFACE_INCLUDE_DIRECTORIES "${SDL2_INCLUDE_DIR}"
+ INTERFACE_LINK_LIBRARIES "${_sdl2_link_libraries}"
++ INTERFACE_LINK_DIRECTORIES "${_sdl2_libdirs}"
+ IMPORTED_LINK_INTERFACE_LANGUAGES "C"
+ IMPORTED_IMPLIB "${_sdl2_implib}"
+ IMPORTED_LOCATION "${_sdl2_dll}"
+@@ -122,6 +130,7 @@ else()
+ set_target_properties(SDL2::SDL2 PROPERTIES
+ INTERFACE_INCLUDE_DIRECTORIES "${SDL2_INCLUDE_DIR}"
+ INTERFACE_LINK_LIBRARIES "${_sdl2_link_libraries}"
++ INTERFACE_LINK_DIRECTORIES "${_sdl2_libdirs}"
+ IMPORTED_LINK_INTERFACE_LANGUAGES "C"
+ IMPORTED_LOCATION "${_sdl2_shared}"
+ )
+@@ -142,6 +151,7 @@ if(EXISTS "${_sdl2_static}")
+ IMPORTED_LOCATION "${_sdl2_static}"
+ INTERFACE_INCLUDE_DIRECTORIES "${SDL2_INCLUDE_DIR}"
+ INTERFACE_LINK_LIBRARIES "${_sdl2_link_libraries};${_sdl2_static_private_libs}"
++ INTERFACE_LINK_DIRECTORIES "${_sdl2_libdirs};${_sdl2_static_private_libdirs}"
+ IMPORTED_LINK_INTERFACE_LANGUAGES "C"
+ )
+ endif()
+
+From: Anonymous Maarten <anonymous.maarten@gmail.com>
+Date: Wed, 24 Aug 2022 04:14:52 +0200
+Subject: [PATCH] cmake: always create SDL2::SDL2main target in autotools'
+ cmake config script
+
+--- a/sdl2-config.cmake.in
++++ b/sdl2-config.cmake.in
+@@ -62,38 +62,39 @@ string(REGEX REPLACE ";-L" ";" _sdl2_static_private_libdirs "${_sdl2_static_priv
+ if(_sdl2_libraries MATCHES ".*SDL2main.*")
+ list(INSERT SDL2_LIBRARIES 0 SDL2::SDL2main)
+ list(INSERT SDL2_STATIC_LIBRARIES 0 SDL2::SDL2main)
+- set(_sdl2main_library ${SDL2_LIBDIR}/${CMAKE_STATIC_LIBRARY_PREFIX}SDL2main${CMAKE_STATIC_LIBRARY_SUFFIX})
+- if(EXISTS "${_sdl2main_library}")
+- set(SDL2MAIN_LIBRARY SDL2::SDL2main)
+- if(NOT TARGET SDL2::SDL2main)
+- add_library(SDL2::SDL2main STATIC IMPORTED)
+- set_target_properties(SDL2::SDL2main
+- PROPERTIES
+- IMPORTED_LOCATION "${_sdl2main_library}"
+- )
+- if(WIN32)
+- # INTERFACE_LINK_OPTIONS needs CMake 3.13
+- cmake_minimum_required(VERSION 3.13)
+- # Mark WinMain/WinMain@16 as undefined, such that it will be withheld by the linker.
+- if(CMAKE_SIZEOF_VOID_P EQUAL 4)
+- set_target_properties(SDL2::SDL2main
+- PROPERTIES
+- INTERFACE_LINK_OPTIONS "-Wl,--undefined=_WinMain@16"
+- )
+- else()
+- set_target_properties(SDL2::SDL2main
+- PROPERTIES
+- INTERFACE_LINK_OPTIONS "-Wl,--undefined=WinMain"
+- )
+- endif()
++endif()
++
++set(_sdl2main_library ${SDL2_LIBDIR}/${CMAKE_STATIC_LIBRARY_PREFIX}SDL2main${CMAKE_STATIC_LIBRARY_SUFFIX})
++if(EXISTS "${_sdl2main_library}")
++ set(SDL2MAIN_LIBRARY SDL2::SDL2main)
++ if(NOT TARGET SDL2::SDL2main)
++ add_library(SDL2::SDL2main STATIC IMPORTED)
++ set_target_properties(SDL2::SDL2main
++ PROPERTIES
++ IMPORTED_LOCATION "${_sdl2main_library}"
++ )
++ if(WIN32)
++ # INTERFACE_LINK_OPTIONS needs CMake 3.13
++ cmake_minimum_required(VERSION 3.13)
++ # Mark WinMain/WinMain@16 as undefined, such that it will be withheld by the linker.
++ if(CMAKE_SIZEOF_VOID_P EQUAL 4)
++ set_target_properties(SDL2::SDL2main
++ PROPERTIES
++ INTERFACE_LINK_OPTIONS "-Wl,--undefined=_WinMain@16"
++ )
++ else()
++ set_target_properties(SDL2::SDL2main
++ PROPERTIES
++ INTERFACE_LINK_OPTIONS "-Wl,--undefined=WinMain"
++ )
+ endif()
+ endif()
+- set(SDL2_SDL2main_FOUND TRUE)
+- else()
+- set(SDL2_SDL2main_FOUND FALSE)
+ endif()
+- unset(_sdl2main_library)
++ set(SDL2_SDL2main_FOUND TRUE)
++else()
++ set(SDL2_SDL2main_FOUND FALSE)
+ endif()
++unset(_sdl2main_library)
+
+ # Remove SDL2 since this is the "central" library
+ # Remove SDL2main since this will be provided by SDL2::SDL2main (if available)
+
diff --git a/media-libs/libsdl2/libsdl2-2.24.0-r1.ebuild b/media-libs/libsdl2/libsdl2-2.24.0-r1.ebuild
new file mode 100644
index 000000000000..6d4ad20ae903
--- /dev/null
+++ b/media-libs/libsdl2/libsdl2-2.24.0-r1.ebuild
@@ -0,0 +1,228 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic multilib-minimal
+
+MY_P="SDL2-${PV}"
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="https://www.libsdl.org/"
+SRC_URI="https://www.libsdl.org/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus doc fcitx4 gles1 gles2 haptic ibus jack +joystick kms libsamplerate nas opengl oss pipewire pulseaudio sndio +sound static-libs +threads udev +video video_cards_vc4 vulkan wayland X xscreensaver"
+REQUIRED_USE="
+ alsa? ( sound )
+ fcitx4? ( dbus )
+ gles1? ( video )
+ gles2? ( video )
+ haptic? ( joystick )
+ ibus? ( dbus )
+ jack? ( sound )
+ nas? ( sound )
+ opengl? ( video )
+ pulseaudio? ( sound )
+ sndio? ( sound )
+ vulkan? ( video )
+ wayland? ( gles2 )
+ xscreensaver? ( X )"
+
+CDEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ fcitx4? ( app-i18n/fcitx:4 )
+ gles1? ( media-libs/mesa[${MULTILIB_USEDEP},gles1] )
+ gles2? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ ibus? ( app-i18n/ibus )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ kms? (
+ >=x11-libs/libdrm-2.4.82[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.0.0[${MULTILIB_USEDEP},gbm(+)]
+ )
+ libsamplerate? ( media-libs/libsamplerate[${MULTILIB_USEDEP}] )
+ nas? (
+ >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ )
+ opengl? (
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ )
+ pipewire? ( media-video/pipewire:=[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ sndio? ( media-sound/sndio:=[${MULTILIB_USEDEP}] )
+ udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? (
+ >=dev-libs/wayland-1.20[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},egl(+),gles2,wayland]
+ >=x11-libs/libxkbcommon-0.2.0[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXcursor-1.1.14[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-6.0.0[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ xscreensaver? ( >=x11-libs/libXScrnSaver-1.2.2-r1[${MULTILIB_USEDEP}] )
+ )"
+RDEPEND="${CDEPEND}
+ vulkan? ( media-libs/vulkan-loader )"
+DEPEND="${CDEPEND}
+ ibus? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
+ vulkan? ( dev-util/vulkan-headers )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ wayland? ( >=dev-util/wayland-scanner-1.20 )
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/SDL2/SDL_config.h
+ /usr/include/SDL2/SDL_platform.h
+ /usr/include/SDL2/begin_code.h
+ /usr/include/SDL2/close_code.h
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.16-static-libs.patch
+ "${FILESDIR}"/${P}-cmake-target-fixes.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Unbundle some headers.
+ rm -r src/video/khronos || die
+ ln -s "${ESYSROOT}/usr/include" src/video/khronos || die
+
+ # SDL seems to customize SDL_config.h.in to remove macros like
+ # PACKAGE_NAME. Add AT_NOEAUTOHEADER="yes" to prevent those macros from
+ # being reintroduced.
+ # https://bugs.gentoo.org/764959
+ AT_NOEAUTOHEADER="yes" AT_M4DIR="/usr/share/aclocal acinclude" \
+ eautoreconf
+}
+
+multilib_src_configure() {
+ use custom-cflags || strip-flags
+
+ if use ibus; then
+ local -x IBUS_CFLAGS="-I${ESYSROOT}/usr/include/ibus-1.0 -I${ESYSROOT}/usr/include/glib-2.0 -I${ESYSROOT}/usr/$(get_libdir)/glib-2.0/include"
+ fi
+
+ # sorted by `./configure --help`
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --enable-atomic
+ $(use_enable sound audio)
+ $(use_enable video)
+ --enable-render
+ --enable-events
+ $(use_enable joystick)
+ $(use_enable haptic)
+ --enable-power
+ --enable-filesystem
+ $(use_enable threads pthreads)
+ --enable-timers
+ --enable-file
+ --enable-loadso
+ --enable-cpuinfo
+ --enable-assembly
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable cpu_flags_x86_sse ssemath)
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_3dnow 3dnow)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable oss)
+ $(use_enable alsa)
+ --disable-alsa-shared
+ $(use_enable jack)
+ --disable-jack-shared
+ --disable-esd
+ $(use_enable pipewire)
+ --disable-pipewire-shared
+ $(use_enable pulseaudio)
+ --disable-pulseaudio-shared
+ --disable-arts
+ $(use_enable libsamplerate)
+ $(use_enable nas)
+ --disable-nas-shared
+ $(use_enable sndio)
+ --disable-sndio-shared
+ $(use_enable sound diskaudio)
+ $(use_enable sound dummyaudio)
+ $(use_enable wayland video-wayland)
+ --disable-wayland-shared
+ $(use_enable video_cards_vc4 video-rpi)
+ $(use_enable X video-x11)
+ --disable-x11-shared
+ $(use_enable X video-x11-xcursor)
+ $(use_enable X video-x11-xdbe)
+ $(use_enable X video-x11-xfixes)
+ $(use_enable X video-x11-xinput)
+ $(use_enable X video-x11-xrandr)
+ $(use_enable xscreensaver video-x11-scrnsaver)
+ $(use_enable X video-x11-xshape)
+ $(use_enable aqua video-cocoa)
+ --disable-video-directfb
+ --disable-fusionsound
+ --disable-fusionsound-shared
+ $(use_enable kms video-kmsdrm)
+ --disable-kmsdrm-shared
+ $(use_enable video video-dummy)
+ $(use_enable opengl video-opengl)
+ $(use_enable gles1 video-opengles1)
+ $(use_enable gles2 video-opengles2)
+ $(use_enable vulkan video-vulkan)
+ $(use_enable udev libudev)
+ $(use_enable dbus)
+ $(use_enable fcitx4 fcitx)
+ $(use_enable ibus)
+ --disable-directx
+ --disable-rpath
+ --disable-render-d3d
+ $(use_with X x)
+ )
+
+ ECONF_SOURCE="${S}" \
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+
+ if use doc; then
+ cd docs || die
+ doxygen || die
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # Do not delete the static .a libraries here as some are
+ # mandatory. They may be needed even when linking dynamically.
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ dodoc {BUGS,CREDITS,README-SDL,TODO,WhatsNew}.txt README.md docs/README*.md
+ use doc && dodoc -r docs/output/html/
+}