summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-09 08:44:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-09 09:07:47 +0100
commit31ec4a2ef621a3a3365476ee50445bce178462b3 (patch)
tree53ee57ef1973247666ef133c694086a314ac6533
parentdev-python/jupyter_client: Bump to 6.1.10 (diff)
downloadgentoo-31ec4a2e.tar.gz
gentoo-31ec4a2e.tar.bz2
gentoo-31ec4a2e.zip
dev-python/setuptools: Bump to 51.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-51.1.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 47daad4dd5d1..81395ce5c3bf 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -2,3 +2,4 @@ DIST setuptools-50.3.0.zip 2169216 BLAKE2B 029ea0159de270af0078a4661c696b93681b3
DIST setuptools-51.0.0.zip 2059134 BLAKE2B 449e87e413490181136ffa80a109e68b086fd0b1b56b2391e8cc612fb4c9cd4bb89acf05b464a5fa86c3984d3f22bc103dc9a21a2948598b7a17f770c4037008 SHA512 ec8c8a43ef176b5a4029f42c900690c1b9cb304efeb2cf8d36f3f2cb4343af4c1b1770f83ffb0e80ef237f58e6eeb233a97d6b3b8c6c6a2557bc4f14ccff9e90
DIST setuptools-51.1.0.tar.gz 2050951 BLAKE2B 58890bf458ffab84f93e68393a092c2b2eeaf28e9e443c9a3cf50fb4bbb371bfe28032d08c5ce92fc0b28ad3f9b718f02542f948560b2a8a57af1ada9e77a949 SHA512 914f0d7692f519b658a55e1c7d96b93a45f34c1682c564c6232cd3771db15c91cfee7118ed61f1ae4655a1afe34c9a9c37f293eb6408eeeeeae9eaa6f3760324
DIST setuptools-51.1.1.tar.gz 2051053 BLAKE2B 182c8c4b4d3bb8caea8cb1812aaff929d7687942d3c469a7f6e0a68a0c5d3d001be2b42d0d131171815359f2c1d59a7b997c5deab657d2ec99c369c6b27ba03f SHA512 ef08f0ecd0b4a255a8e43c2785c2a1ce76f807322c3358b7955d2ea814f9fa3f52962f7cd0431439ef9ee910fd44922d1be1888c350703031cfcab8db0f60ce7
+DIST setuptools-51.1.2.tar.gz 2051107 BLAKE2B a9f1d5dac6bed7b8744f1a3f023398312f6e3696ea68a84bdb252afca3e88b8617ae632384c18cf49906b1ec97f78f467ec158cc09e1842055b5089e154e0429 SHA512 cdfdb3c3666239268ab225704d1a887f027c297262521ee8d55af547cbcef0931656997cc86f4f9a871df6028974bd90b9eea6177c02bf34f98297415b9c410f
diff --git a/dev-python/setuptools/setuptools-51.1.2.ebuild b/dev-python/setuptools/setuptools-51.1.2.ebuild
new file mode 100644
index 000000000000..8d193ccb0410
--- /dev/null
+++ b/dev-python/setuptools/setuptools-51.1.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst )
+
+python_test() {
+ distutils_install_for_testing --via-root
+ local deselect=(
+ # TODO
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ # this one's unhappy about pytest-xdist but one test is not worth
+ # losing the speed gain
+ setuptools/tests/test_build_meta.py::TestBuildMetaBackend::test_build_sdist_relative_path_import
+ )
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${deselect[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+ setuptools || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}