summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-25 15:36:55 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-25 15:55:06 -0700
commit31fe4f98334024bbb8f99fc16c75ac442f179a22 (patch)
tree38a012f0715ec4285c2003df5bde35ddfd7073f4
parentnet-libs/grpc: bump to 1.32.0 (diff)
downloadgentoo-31fe4f98.tar.gz
gentoo-31fe4f98.tar.bz2
gentoo-31fe4f98.zip
dev-python/grpcio: bump to 1.32.0
Bug: https://bugs.gentoo.org/744619 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/files/1.32.0-setup.py-respect-CC-variable-in-latomic-test.patch28
-rw-r--r--dev-python/grpcio/grpcio-1.32.0.ebuild43
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index 8103d8c72046..8b912edf166e 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1 +1,2 @@
DIST grpcio-1.28.1.tar.gz 19511346 BLAKE2B 01ebdeddcba5efbb67880693ede04ccd828771fe73def24a91d882c28f5cf6f14215daca212df1d8bb9372f385aff1e31418870437c87343f218e7b78a06b04c SHA512 12feaee3816a5e7b20b648a144d37f7e550a057112f5460bc4ec016885461951148cd4d2900fbfc905f76059ef29ae4c4d1d5a3216e5e3a2d17048c8b45f394f
+DIST grpcio-1.32.0.tar.gz 20809917 BLAKE2B e28cb44d09fd775b9b6dc87dcd52bf7f144643b09912ff8b76bf39cb250743f90bc7e3769252d47f205f9532157ae68b6ac0a9202158cb14e7b9ad448d951656 SHA512 f802a7b83bd166502fdcbfaf162652adcda36da1b2e91b5073e3b3d97d38191fe989a6dcbec6c1bf27fff162633e54bdbdb20a92e74e14280fac4576baa92157
diff --git a/dev-python/grpcio/files/1.32.0-setup.py-respect-CC-variable-in-latomic-test.patch b/dev-python/grpcio/files/1.32.0-setup.py-respect-CC-variable-in-latomic-test.patch
new file mode 100644
index 000000000000..c6729e9808b4
--- /dev/null
+++ b/dev-python/grpcio/files/1.32.0-setup.py-respect-CC-variable-in-latomic-test.patch
@@ -0,0 +1,28 @@
+From c8e7e1c3cd55bf44b6fad6afa716dec9de3bf14f Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Fri, 25 Sep 2020 15:34:19 -0700
+Subject: [PATCH] setup.py: respect CC variable in latomic test
+
+---
+ setup.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 20a6d76..d1cd707 100644
+--- a/setup.py
++++ b/setup.py
+@@ -164,9 +164,10 @@ ENABLE_DOCUMENTATION_BUILD = os.environ.get(
+
+ def check_linker_need_libatomic():
+ """Test if linker on system needs libatomic."""
++ cc = os.environ.get('CC', 'cc')
+ code_test = (b'#include <atomic>\n' +
+ b'int main() { return std::atomic<int64_t>{}; }')
+- cc_test = subprocess.Popen(['cc', '-x', 'c++', '-std=c++11', '-'],
++ cc_test = subprocess.Popen([cc, '-x', 'c++', '-std=c++11', '-'],
+ stdin=PIPE,
+ stdout=PIPE,
+ stderr=PIPE)
+--
+2.28.0
+
diff --git a/dev-python/grpcio/grpcio-1.32.0.ebuild b/dev-python/grpcio/grpcio-1.32.0.ebuild
new file mode 100644
index 000000000000..d5fdc2f0f42b
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.32.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 multiprocessing prefix
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-libs/openssl-1.0.2:0=[-bindist]
+ >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ sys-libs/zlib:=
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/1.32.0-setup.py-respect-CC-variable-in-latomic-test.patch" )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ hprefixify setup.py
+}
+
+python_configure_all() {
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}