summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-25 16:56:06 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-25 16:59:12 -0400
commit321db730ab709509a023f4d6a728eb84fa43add3 (patch)
tree25b8d444bb8e8ed90100fd06ee7187754600b860
parentx11-wm/mutter: Version bump to 44.1 (diff)
downloadgentoo-321db730ab709509a023f4d6a728eb84fa43add3.tar.gz
gentoo-321db730ab709509a023f4d6a728eb84fa43add3.tar.bz2
gentoo-321db730ab709509a023f4d6a728eb84fa43add3.zip
gnome-base/gnome-shell: Version bump to 44.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-base/gnome-shell/Manifest1
-rw-r--r--gnome-base/gnome-shell/gnome-shell-44.1.ebuild182
2 files changed, 183 insertions, 0 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index bf074e30e8c4..49ebda418297 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1,3 +1,4 @@
DIST gnome-shell-43.3.tar.xz 1953404 BLAKE2B a3ba8bfa5dcd65b50228b447a20d8f50d6fea1b18c36383214fb055491ea5baf43caa227ecac7c7d59a2f3d56bb25fbf04209cdeff32370e01af0b7f5aa8b97a SHA512 6d2a36b21b1e3d1bd8667c72ff2c2cf4e57a3b0abbcb9b4e115803ec727b892f5884ba7aa48412396c855294c58e862dd2d972e1d6bed0de657e208f4c4aaab9
DIST gnome-shell-43.4.tar.xz 1951664 BLAKE2B c68b58b90886945726d3bb8dfef503703dab406e89aa8633f6327315e6b3c295783b1351252ccc907d31e834eb078708919b64d02b01c70e32da2034acc1d0d8 SHA512 6bcc0b943352c89771372477ebf829ea96d54cca6dd3e10556eb1d0023c1a84b94198f40e31fb95ae6b866e29ea120c74797c7e20b07fe5f61a274ac527d4895
DIST gnome-shell-44.0.tar.xz 1992764 BLAKE2B 2d8ccb04c143e174c992bfecc9e5c8f78025db9af741ed120713c8fcb934def98e182cf6f993c1fafb5088b70759c1742329134fa87cf0288fbec018d174fff2 SHA512 5e19e3e3b06be6b06699f49501dee85fd21e5f4f394902732c505c24baa16a719848e31034d98718deb06cb004d3e8daf886a086412c2b67614eafecd1676bde
+DIST gnome-shell-44.1.tar.xz 1994844 BLAKE2B fa268b7c98db881dc3b397405128d001d354c9b67c7cf8b129c49ac9bb44a80b79fbdb0fcaca286e14b1bc58df72f722ff293104817b636aff97e5578849b985 SHA512 f21211e5e5146b885345d3e1a99702a3119e4dfc25860fe4f7bdbc3a04db2480f03f4e9898e46e4485048035584cbbcf6ef17c396b857c194ad5645aa7d78be7
diff --git a/gnome-base/gnome-shell/gnome-shell-44.1.ebuild b/gnome-base/gnome-shell/gnome-shell-44.1.ebuild
new file mode 100644
index 000000000000..638f1c5e3c69
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-44.1.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome.org gnome2-utils meson optfeature python-single-r1 virtualx xdg
+
+DESCRIPTION="Provides core UI functions for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell https://gitlab.gnome.org/GNOME/gnome-shell"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind gtk-doc +ibus +networkmanager systemd test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( elogind systemd )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# libXfixes-5.0 needed for pointer barriers and #include <X11/extensions/Xfixes.h>
+DEPEND="
+ >=gnome-extra/evolution-data-server-3.46.0:=
+ >=app-crypt/gcr-3.90.0:4=[introspection]
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/gobject-introspection-1.49.1:=
+ >=dev-libs/gjs-1.73.1[cairo]
+ >=x11-libs/gtk+-3.15.0:3[introspection]
+ >=x11-wm/mutter-44.0:0/12[introspection,test?]
+ >=sys-auth/polkit-0.120_p20220509[introspection]
+ >=gnome-base/gsettings-desktop-schemas-42_beta[introspection]
+ >=x11-libs/startup-notification-0.11
+ >=app-i18n/ibus-1.5.19
+ >=gnome-base/gnome-desktop-40.0:4
+ networkmanager? (
+ >=net-misc/networkmanager-1.10.4[introspection]
+ net-libs/libnma[introspection]
+ >=app-crypt/libsecret-0.18
+ dev-libs/dbus-glib
+ )
+ systemd? (
+ >=sys-apps/systemd-242:=
+ >=gnome-base/gnome-desktop-3.34.2:3=[systemd]
+ )
+ elogind? ( >=sys-auth/elogind-237 )
+
+ app-arch/gnome-autoar
+ dev-libs/json-glib
+
+ >=app-accessibility/at-spi2-core-2.46:2[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ dev-libs/libxml2:2
+ x11-libs/libX11
+
+ >=media-libs/libpulse-2[glib]
+ dev-libs/libical:=
+ >=x11-libs/libXfixes-5.0
+
+ gui-libs/gtk:4[introspection]
+
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ media-libs/libglvnd[X]
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Introspection deps generated from inspection of the output of:
+# for i in `rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- |sort -u`; do echo $i ;done |cut -d, -f1 |sort -u
+# or
+# rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- | sed -e 's:[{}]::g' | awk '{$1=$1; print}' | awk -F',' '{$1=$1;print}' | tr ' ' '\n' | sort -u | sed -e 's/://g'
+# These will give a lot of unnecessary things due to greedy matching (TODO), and `(?s).*?` doesn't seem to work as desired.
+# Compare with `grep -rhI 'imports.gi.versions' |sort -u` for any SLOT requirements
+# Each block:
+# 1. Introspection stuff needed via imports.gi (those that build time check may be listed above already)
+# 2. gnome-session needed for shutdown/reboot/inhibitors/etc
+# 3. Control shell settings
+# 4. xdg-utils needed for xdg-open, used by extension tool
+# 5. adwaita-icon-theme needed for various icons & arrows (3.26 for new video-joined-displays-symbolic and co icons; review for 3.28+)
+# 6. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c # TODO: Review
+# 7. IBus is needed for nls integration
+# 8. Cantarell font used in gnome-shell global CSS (if removing this for some reason, make sure it's pulled in somehow for non-meta users still too)
+# 9. xdg-desktop-portal-gtk for various integration, e.g. #764632
+# 10. TODO: semi-optional webkit-gtk[introspection] for captive portal helper
+RDEPEND="${DEPEND}
+ >=sys-apps/accountsservice-0.6.14[introspection]
+ app-accessibility/at-spi2-core:2[introspection]
+ app-misc/geoclue[introspection]
+ media-libs/graphene[introspection]
+ x11-libs/pango[introspection]
+ net-libs/libsoup:3.0[introspection]
+ >=sys-power/upower-0.99:=[introspection]
+ gnome-base/librsvg:2[introspection]
+
+ >=gnome-base/gnome-session-2.91.91
+ >=gnome-base/gnome-settings-daemon-3.8.3
+
+ x11-misc/xdg-utils
+
+ >=x11-themes/adwaita-icon-theme-3.26
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data
+ )
+ ibus? ( >=app-i18n/ibus-1.5.26[gtk3,gtk4,introspection] )
+ media-fonts/cantarell
+
+ sys-apps/xdg-desktop-portal-gnome
+"
+# avoid circular dependency, see bug #546134
+PDEPEND="
+ >=gnome-base/gdm-3.5[introspection(+)]
+ >=gnome-base/gnome-control-center-3.26[networkmanager(+)?]
+"
+BDEPEND="
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.45.3
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.17
+ app-text/docbook-xml-dtd:4.5 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( x11-wm/mutter[test] )
+"
+# These are not needed from tarballs, unless stylesheets or manpage get patched with patchset:
+# dev-lang/sassc
+# app-text/asciidoc
+
+PATCHES=(
+ # Change favorites defaults, bug #479918
+ "${FILESDIR}"/40.0-defaults.patch
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ # Hack in correct python shebang
+ sed -e "s:python\.full_path():'/usr/bin/env ${EPYTHON}':" -i src/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dextensions_tool=true
+ -Dextensions_app=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dman=true
+ $(meson_use test tests)
+ $(meson_use networkmanager)
+ $(meson_use systemd) # this controls journald integration and desktop file user services related property only as of 3.34.4
+ # (structured logging and having gnome-shell launched apps use its own identifier instead of gnome-session)
+ # suspend support is runtime optional via /run/systemd/seats presence and org.freedesktop.login1.Manager dbus interface; elogind should provide what's necessary
+ -Dsoup2=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "media-libs/mesa[llvm]"; then
+ elog "llvmpipe is used as fallback when no 3D acceleration"
+ elog "is available. You will need to enable llvm USE for"
+ elog "media-libs/mesa if you do not have hardware 3D setup."
+ fi
+
+ optfeature "Bluetooth integration" gnome-base/gnome-control-center[bluetooth] net-wireless/gnome-bluetooth:3[introspection]
+ optfeature "Browser extension integration" gnome-extra/gnome-browser-connector
+ optfeature "Screencast/capture support" media-video/pipewire media-libs/gstreamer[introspection] media-libs/gst-plugins-base[introspection] media-libs/gst-plugins-good media-plugins/gst-plugins-vpx
+ optfeature "Weather support" dev-libs/libgweather:4[introspection]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}