summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Gysel <me@bearsh.org>2023-12-23 16:08:16 +0100
committerSam James <sam@gentoo.org>2023-12-23 17:30:25 +0000
commit32235eb79dd29af102e4c5a654a928013ece57b1 (patch)
tree97b0a4d6de0db29960219b31568ac17f79a55bb4
parentdev-vcs/git-cola: add 4.4.1 (diff)
downloadgentoo-32235eb79dd29af102e4c5a654a928013ece57b1.tar.gz
gentoo-32235eb79dd29af102e4c5a654a928013ece57b1.tar.bz2
gentoo-32235eb79dd29af102e4c5a654a928013ece57b1.zip
dev-vcs/git-cola: 4.2.1: fix setuptools-69 breakage
See also: https://github.com/git-cola/git-cola/commit/b53983c7fa7d29dd6f474177015fcb6f2ee0e6d1 Bug: https://bugs.gentoo.org/920534 Signed-off-by: Martin Gysel <me@bearsh.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-vcs/git-cola/files/git-cola-4.2.1-fix-setuptools.patch24
-rw-r--r--dev-vcs/git-cola/git-cola-4.2.1-r1.ebuild (renamed from dev-vcs/git-cola/git-cola-4.2.1.ebuild)2
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-vcs/git-cola/files/git-cola-4.2.1-fix-setuptools.patch b/dev-vcs/git-cola/files/git-cola-4.2.1-fix-setuptools.patch
new file mode 100644
index 000000000000..d1453c3f163e
--- /dev/null
+++ b/dev-vcs/git-cola/files/git-cola-4.2.1-fix-setuptools.patch
@@ -0,0 +1,24 @@
+From b53983c7fa7d29dd6f474177015fcb6f2ee0e6d1 Mon Sep 17 00:00:00 2001
+From: David Aguilar <davvid@gmail.com>
+Date: Thu, 2 Nov 2023 01:33:16 -0700
+Subject: [PATCH] pyproject.toml: list dependencies and optional-dependencies
+ as dynamic
+
+Signed-off-by: David Aguilar <davvid@gmail.com>
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 20b3008e0..97cdf79b4 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -13,7 +13,7 @@ classifiers = [
+ "Topic :: Software Development :: Version Control :: Git",
+ ]
+ description = "A sleek and powerful Git GUI"
+-dynamic = ["version"]
++dynamic = ["dependencies", "optional-dependencies", "version"]
+ license = {file = "COPYING"}
+ readme = "README.md"
+
diff --git a/dev-vcs/git-cola/git-cola-4.2.1.ebuild b/dev-vcs/git-cola/git-cola-4.2.1-r1.ebuild
index 79239901785f..14d1a8b01c21 100644
--- a/dev-vcs/git-cola/git-cola-4.2.1.ebuild
+++ b/dev-vcs/git-cola/git-cola-4.2.1-r1.ebuild
@@ -38,6 +38,8 @@ BDEPEND="sys-devel/gettext
)
")
"
+# https://bugs.gentoo.org/920534
+PATCHES=( "${FILESDIR}/${P}-fix-setuptools.patch" )
distutils_enable_sphinx docs \
'dev-python/rst-linker'