summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-05-29 21:40:02 +0200
committerSam James <sam@gentoo.org>2023-05-29 22:55:01 +0100
commit3244fceeb1503d40d3a39ad02077d35834d1a9bd (patch)
tree7f22bc30bcde42bc284dd8dba0a61488dae59575
parentdev-python/sphinxcontrib-htmlhelp: enable py3.12 (diff)
downloadgentoo-3244fceeb1503d40d3a39ad02077d35834d1a9bd.tar.gz
gentoo-3244fceeb1503d40d3a39ad02077d35834d1a9bd.tar.bz2
gentoo-3244fceeb1503d40d3a39ad02077d35834d1a9bd.zip
dev-python/sphinxcontrib-jsmath: enable py3.12
This also fixes failing test. Closes: https://bugs.gentoo.org/858812 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r3.ebuild b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..a153b591a758
--- /dev/null
+++ b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which renders display math in HTML via JavaScript"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-jsmath/
+ https://pypi.org/project/sphinxcontrib-jsmath/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # This is already fixed in upstream, remove it on next version bump,
+ # see https://github.com/sphinx-doc/sphinxcontrib-jsmath/pull/10
+ sed -i 's/.text()/.read_text()/' tests/test_jsmath.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}