summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-09 01:23:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-09 01:24:58 +0200
commit327015f8d08cabb88de219471493d9b55ac1fb20 (patch)
tree8856cc4e884d4c1b77f01f3a7fda93b7d1b8ce11
parentdev-python/clang-python: Use https for llvm.org (diff)
downloadgentoo-327015f8.tar.gz
gentoo-327015f8.tar.bz2
gentoo-327015f8.zip
dev-util/lldb: Use https for llvm.org
-rw-r--r--dev-util/lldb/lldb-4.0.0-r1.ebuild6
-rw-r--r--dev-util/lldb/lldb-4.0.1.ebuild6
-rw-r--r--dev-util/lldb/lldb-9999.ebuild4
3 files changed, 8 insertions, 8 deletions
diff --git a/dev-util/lldb/lldb-4.0.0-r1.ebuild b/dev-util/lldb/lldb-4.0.0-r1.ebuild
index c247c6f25c9d..64a83e7105da 100644
--- a/dev-util/lldb/lldb-4.0.0-r1.ebuild
+++ b/dev-util/lldb/lldb-4.0.0-r1.ebuild
@@ -11,9 +11,9 @@ PYTHON_COMPAT=( python2_7 )
inherit cmake-utils llvm python-single-r1 toolchain-funcs
DESCRIPTION="The LLVM debugger"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz
- test? ( http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz )"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz
+ test? ( https://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz )"
LICENSE="UoI-NCSA"
SLOT="0"
diff --git a/dev-util/lldb/lldb-4.0.1.ebuild b/dev-util/lldb/lldb-4.0.1.ebuild
index c247c6f25c9d..64a83e7105da 100644
--- a/dev-util/lldb/lldb-4.0.1.ebuild
+++ b/dev-util/lldb/lldb-4.0.1.ebuild
@@ -11,9 +11,9 @@ PYTHON_COMPAT=( python2_7 )
inherit cmake-utils llvm python-single-r1 toolchain-funcs
DESCRIPTION="The LLVM debugger"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz
- test? ( http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz )"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz
+ test? ( https://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz )"
LICENSE="UoI-NCSA"
SLOT="0"
diff --git a/dev-util/lldb/lldb-9999.ebuild b/dev-util/lldb/lldb-9999.ebuild
index 45a14965b4f0..5016f336d614 100644
--- a/dev-util/lldb/lldb-9999.ebuild
+++ b/dev-util/lldb/lldb-9999.ebuild
@@ -11,7 +11,7 @@ PYTHON_COMPAT=( python2_7 )
inherit cmake-utils git-r3 llvm python-single-r1 toolchain-funcs
DESCRIPTION="The LLVM debugger"
-HOMEPAGE="http://llvm.org/"
+HOMEPAGE="https://llvm.org/"
SRC_URI=""
EGIT_REPO_URI="https://git.llvm.org/git/lldb.git
https://github.com/llvm-mirror/lldb.git"
@@ -55,7 +55,7 @@ src_unpack() {
git-r3_fetch
if use test; then
- git-r3_checkout http://llvm.org/git/llvm.git \
+ git-r3_checkout https://llvm.org/git/llvm.git \
"${WORKDIR}"/llvm
fi
git-r3_checkout