summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-25 15:03:51 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-25 15:03:51 +0200
commit327069aff4a3186dacb7f5da192af2e8dc27f729 (patch)
treefb79f714b90ab3bbebe1301baf055614db7694c7
parentdev-python/fakeredis: Remove dev-python/aioredis optfeature (diff)
downloadgentoo-327069af.tar.gz
gentoo-327069af.tar.bz2
gentoo-327069af.zip
media-libs/libgroove: treeclean
Closes: https://bugs.gentoo.org/834383 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--media-libs/libgroove/Manifest1
-rw-r--r--media-libs/libgroove/files/libgroove-4.3.0_GNUInstallDirs.patch105
-rw-r--r--media-libs/libgroove/files/libgroove-4.3.0_cflags.patch43
-rw-r--r--media-libs/libgroove/files/libgroove-4.3.0_ffmpeg4.patch47
-rw-r--r--media-libs/libgroove/files/libgroove-4.3.0_sdl2_include_dir.patch13
-rw-r--r--media-libs/libgroove/libgroove-4.3.0-r1.ebuild43
-rw-r--r--media-libs/libgroove/metadata.xml21
-rw-r--r--profiles/package.mask5
8 files changed, 0 insertions, 278 deletions
diff --git a/media-libs/libgroove/Manifest b/media-libs/libgroove/Manifest
deleted file mode 100644
index 07097eaad32f..000000000000
--- a/media-libs/libgroove/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libgroove-4.3.0.tar.gz 48857 BLAKE2B 40659e84a00245791746c570ba667cb97ba61de2bf9c1e746aaacb02db4ef5d15a00561aed7001f9a9a7b20ad8645f74c12a836b8bd59ebbc1abbda045d558d0 SHA512 30d75a3b1b3efa9b33687bb146648b66f8f4c718551c0db2c24c0259f09cf355a7c7bbac40d60d7a97bbbd7f83401d09464c6ac2b18cdfcd6198220cefc8a705
diff --git a/media-libs/libgroove/files/libgroove-4.3.0_GNUInstallDirs.patch b/media-libs/libgroove/files/libgroove-4.3.0_GNUInstallDirs.patch
deleted file mode 100644
index a4e77b87ce74..000000000000
--- a/media-libs/libgroove/files/libgroove-4.3.0_GNUInstallDirs.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-From 8b741249fc17d7cf7d72a702fcdf7f07870b0b27 Mon Sep 17 00:00:00 2001
-From: hasufell <hasufell@hasufell.de>
-Date: Thu, 20 Aug 2015 14:30:16 +0200
-Subject: [PATCH] CMake: make installation directories more configurable
-
-We use GNUInstallDirs now to be able to control the following variables:
- CMAKE_INSTALL_LIBDIR
- CMAKE_INSTALL_INCLUDEDIR
-
-This fixes support for distribution that have a multi-arch setup.
-Also see https://github.com/gentoo/gentoo/pull/22
----
- CMakeLists.txt | 26 ++++++++++++++------------
- 1 file changed, 14 insertions(+), 12 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f2029eb..49e150e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,4 +1,6 @@
--cmake_minimum_required(VERSION 2.8)
-+cmake_minimum_required(VERSION 2.8.5)
-+
-+include(GNUInstallDirs)
-
- if(NOT CMAKE_BUILD_TYPE)
- set(CMAKE_BUILD_TYPE "Debug" CACHE STRING
-@@ -157,7 +159,7 @@ add_library(groove_static STATIC ${LIBGROOVE_SOURCES} ${LIBGROOVE_HEADERS})
- set_target_properties(groove_static PROPERTIES
- OUTPUT_NAME groove
- COMPILE_FLAGS "${LIB_CFLAGS} -fPIC")
--install(TARGETS groove_static DESTINATION lib)
-+install(TARGETS groove_static DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
-
- install(FILES
-@@ -165,7 +167,7 @@ install(FILES
- "groove/queue.h"
- "groove/encoder.h"
- DESTINATION "include/groove")
--install(TARGETS groove DESTINATION lib)
-+install(TARGETS groove DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
- add_executable(metadata example/metadata.c)
- set_target_properties(metadata PROPERTIES
-@@ -207,8 +209,8 @@ else()
- target_link_libraries(grooveplayer LINK_PRIVATE ${SDL2_LIBRARY})
- include_directories(${SDL2_INCLUDE_DIR})
-
-- install(FILES "grooveplayer/player.h" DESTINATION "include/grooveplayer")
-- install(TARGETS grooveplayer DESTINATION lib)
-+ install(FILES "grooveplayer/player.h" DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/grooveplayer")
-+ install(TARGETS grooveplayer DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
- add_library(grooveplayer_static STATIC
- ${LIBGROOVE_PLAYER_SOURCES}
-@@ -216,7 +218,7 @@ else()
- set_target_properties(grooveplayer_static PROPERTIES
- OUTPUT_NAME grooveplayer
- COMPILE_FLAGS "${LIB_CFLAGS} -fPIC")
-- install(TARGETS grooveplayer_static DESTINATION lib)
-+ install(TARGETS grooveplayer_static DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
-
- add_executable(playlist example/playlist.c ${PROJECT_SOURCE_DIR}/grooveplayer/player.h)
-@@ -242,8 +244,8 @@ else()
- target_link_libraries(grooveloudness LINK_PRIVATE ${EBUR128_LIBRARY})
- include_directories(${EBUR128_INCLUDE_DIR})
-
-- install(FILES "grooveloudness/loudness.h" DESTINATION "include/grooveloudness")
-- install(TARGETS grooveloudness DESTINATION lib)
-+ install(FILES "grooveloudness/loudness.h" DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/grooveloudness")
-+ install(TARGETS grooveloudness DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
-
- add_library(grooveloudness_static STATIC
-@@ -252,7 +254,7 @@ else()
- set_target_properties(grooveloudness_static PROPERTIES
- OUTPUT_NAME grooveloudness
- COMPILE_FLAGS "${LIB_CFLAGS} -fPIC")
-- install(TARGETS grooveloudness_static DESTINATION lib)
-+ install(TARGETS grooveloudness_static DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
-
- add_executable(replaygain example/replaygain.c)
-@@ -278,8 +280,8 @@ else()
- target_link_libraries(groovefingerprinter LINK_PRIVATE ${CHROMAPRINT_LIBRARY})
- include_directories(${CHROMAPRINT_INCLUDE_DIR})
-
-- install(FILES "groovefingerprinter/fingerprinter.h" DESTINATION "include/groovefingerprinter")
-- install(TARGETS groovefingerprinter DESTINATION lib)
-+ install(FILES "groovefingerprinter/fingerprinter.h" DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/groovefingerprinter")
-+ install(TARGETS groovefingerprinter DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
-
- add_library(groovefingerprinter_static STATIC
-@@ -288,7 +290,7 @@ else()
- set_target_properties(groovefingerprinter_static PROPERTIES
- OUTPUT_NAME groovefingerprinter
- COMPILE_FLAGS "${LIB_CFLAGS} -fPIC")
-- install(TARGETS groovefingerprinter_static DESTINATION lib)
-+ install(TARGETS groovefingerprinter_static DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
-
- add_executable(fingerprint example/fingerprint.c)
diff --git a/media-libs/libgroove/files/libgroove-4.3.0_cflags.patch b/media-libs/libgroove/files/libgroove-4.3.0_cflags.patch
deleted file mode 100644
index c7d21cbe2de4..000000000000
--- a/media-libs/libgroove/files/libgroove-4.3.0_cflags.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From e5af72acd284db1ee2b79aeeb06714770d1ad5c3 Mon Sep 17 00:00:00 2001
-From: Diogo Pereira <sir.suriv@gmail.com>
-Date: Thu, 20 Aug 2015 15:05:25 +0100
-Subject: [PATCH] Remove -Werror, -pedantic and -g from CFLAGS
-
-Based on upstream commits:
-0b619fa build: -Werror and -pedantic in debug mode only
-856c260 build: remove redundant -Werror and -pedantic
-
-https://github.com/andrewrk/libgroove/compare/44aa5db96cfe45e56fa1f7d762fb032ca178a35c...856c26013e4356d4fc078da980083bc4d002771d
----
- CMakeLists.txt | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a1e8541..14aca44 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -135,8 +135,11 @@ configure_file (
- "${PROJECT_BINARY_DIR}/config.h"
- )
-
--set(LIB_CFLAGS "${C99_C_FLAGS} -pedantic -Werror -Wall -Werror=strict-prototypes -Werror=old-style-definition -Werror=missing-prototypes -D_REENTRANT -D_POSIX_C_SOURCE=200809L")
--set(EXAMPLE_CFLAGS "${C99_C_FLAGS} -pedantic -Werror -Wall -g")
-+set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -Wno-unused-variable")
-+set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror -pedantic")
-+
-+set(LIB_CFLAGS "-std=c99 -Wall -Werror=strict-prototypes -Werror=old-style-definition -Werror=missing-prototypes -D_REENTRANT -D_POSIX_C_SOURCE=200809L")
-+set(EXAMPLE_CFLAGS "-std=c99 -Wall")
- set(EXAMPLE_INCLUDES "${PROJECT_SOURCE_DIR}")
-
- add_library(groove SHARED ${LIBGROOVE_SOURCES} ${LIBGROOVE_HEADERS})
-@@ -306,6 +309,7 @@ message("\n"
- "Installation Summary\n"
- "--------------------\n"
- "* Install Directory : ${CMAKE_INSTALL_PREFIX}\n"
-+"* Build Type : ${CMAKE_BUILD_TYPE}\n"
- "* Build libgroove : ${LIBGROOVE_STATUS}\n"
- "* Build libgrooveplayer : ${LIBGROOVE_PLAYER_STATUS}\n"
- "* Build libgrooveloudness : ${LIBGROOVE_LOUDNESS_STATUS}\n"
---
-2.5.0
-
diff --git a/media-libs/libgroove/files/libgroove-4.3.0_ffmpeg4.patch b/media-libs/libgroove/files/libgroove-4.3.0_ffmpeg4.patch
deleted file mode 100644
index eadc4d98a913..000000000000
--- a/media-libs/libgroove/files/libgroove-4.3.0_ffmpeg4.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Description: Fix FTBFS with FFmpeg 4.0
-Author: James Cowgill <jcowgill@debian.org>
-Bug-Debian: https://bugs.debian.org/888376
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/groove/encoder.c
-+++ b/groove/encoder.c
-@@ -616,7 +616,7 @@ int groove_encoder_attach(struct GrooveE
-
- e->sink->audio_format = encoder->actual_audio_format;
- e->sink->buffer_size = encoder->sink_buffer_size;
-- e->sink->buffer_sample_count = (codec->capabilities & CODEC_CAP_VARIABLE_FRAME_SIZE) ?
-+ e->sink->buffer_sample_count = (codec->capabilities & AV_CODEC_CAP_VARIABLE_FRAME_SIZE) ?
- 0 : e->stream->codec->frame_size;
- e->sink->gain = encoder->gain;
-
---- a/groove/playlist.c
-+++ b/groove/playlist.c
-@@ -186,7 +186,7 @@ static int audio_decode_frame(struct Gro
-
- if (!got_frame) {
- // stop sending empty packets if the decoder is finished
-- if (!pkt_temp->data && dec->codec->capabilities & CODEC_CAP_DELAY)
-+ if (!pkt_temp->data && dec->codec->capabilities & AV_CODEC_CAP_DELAY)
- return 0;
- continue;
- }
-@@ -571,7 +571,7 @@ static int decode_one_frame(struct Groov
- pthread_mutex_unlock(&f->seek_mutex);
-
- if (f->eof) {
-- if (f->audio_st->codec->codec->capabilities & CODEC_CAP_DELAY) {
-+ if (f->audio_st->codec->codec->capabilities & AV_CODEC_CAP_DELAY) {
- av_init_packet(pkt);
- pkt->data = NULL;
- pkt->size = 0;
---- a/groove/file.c
-+++ b/groove/file.c
-@@ -281,7 +281,7 @@ int groove_file_save(struct GrooveFile *
- ocodec->rc_buffer_size = icodec->rc_buffer_size;
- ocodec->field_order = icodec->field_order;
-
-- uint64_t extra_size = (uint64_t)icodec->extradata_size + FF_INPUT_BUFFER_PADDING_SIZE;
-+ uint64_t extra_size = (uint64_t)icodec->extradata_size + AV_INPUT_BUFFER_PADDING_SIZE;
- if (extra_size > INT_MAX) {
- cleanup_save(file);
- av_log(NULL, AV_LOG_ERROR, "codec extra size too big\n");
diff --git a/media-libs/libgroove/files/libgroove-4.3.0_sdl2_include_dir.patch b/media-libs/libgroove/files/libgroove-4.3.0_sdl2_include_dir.patch
deleted file mode 100644
index 7967c23c973e..000000000000
--- a/media-libs/libgroove/files/libgroove-4.3.0_sdl2_include_dir.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a1e8541..80a96c2 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -208,7 +208,7 @@ else()
- endif()
- add_dependencies(grooveplayer groove)
- target_link_libraries(grooveplayer LINK_PRIVATE ${SDL2_LIBRARY})
-- include_directories(${SDL2_INCLUDE_DIR})
-+ include_directories(${SDL2_INCLUDE_DIR} "${SDL2_INCLUDE_DIR}/SDL2")
-
- install(FILES "grooveplayer/player.h" DESTINATION "include/grooveplayer")
- install(TARGETS grooveplayer DESTINATION lib)
diff --git a/media-libs/libgroove/libgroove-4.3.0-r1.ebuild b/media-libs/libgroove/libgroove-4.3.0-r1.ebuild
deleted file mode 100644
index 2b45f178d15b..000000000000
--- a/media-libs/libgroove/libgroove-4.3.0-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Streaming audio processing library"
-HOMEPAGE="https://github.com/andrewrk/libgroove"
-SRC_URI="https://github.com/andrewrk/libgroove/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/4"
-KEYWORDS="~amd64"
-IUSE="+chromaprint +loudness +sound"
-
-DEPEND="
- media-video/ffmpeg:=
- chromaprint? ( media-libs/chromaprint:= )
- loudness? ( media-libs/libebur128:=[speex(+)] )
- sound? ( media-libs/libsdl2[sound] )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${P}_cflags.patch"
- "${FILESDIR}/${P}_sdl2_include_dir.patch"
- "${FILESDIR}/${P}_ffmpeg4.patch"
- "${FILESDIR}/${P}_GNUInstallDirs.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DDISABLE_FINGERPRINTER=$(usex !chromaprint)
- -DDISABLE_LOUDNESS=$(usex !loudness)
- -DDISABLE_PLAYER=$(usex !sound)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- rm "${ED}"/usr/$(get_libdir)/*.a || die "failed to remove static libs"
-}
diff --git a/media-libs/libgroove/metadata.xml b/media-libs/libgroove/metadata.xml
deleted file mode 100644
index 59a78738e302..000000000000
--- a/media-libs/libgroove/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription lang="en">
- This library provides decoding and encoding of audio on a playlist. It is intended to be used as a backend for music player applications. That said, it is also generic enough to be used as a backend for any streaming audio processing utility.
-</longdescription>
-<use>
- <flag name="chromaprint">Enable audio fingerprinting using <pkg>media-libs/chromaprint</pkg>.</flag>
- <flag name="loudness">Enable loudness detection according to the EBU R128 standard using <pkg>media-libs/libebur128</pkg>.</flag>
- <flag name="sound">Enable audio playing.</flag>
-</use>
-<upstream>
- <maintainer status="inactive">
- <email>superjoe30@gmail.com</email>
- <name>Andrew Kelley</name>
- </maintainer>
- <remote-id type="github">andrewrk/libgroove</remote-id>
- <bugs-to>https://github.com/andrewrk/libgroove/issues</bugs-to>
-</upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 2a492c5883f0..594dff63a6bc 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -290,11 +290,6 @@ app-misc/zygrib
# Bug #682346, #844592, removal on 2022-08-27.
app-crypt/kbfs
-# Sam James <sam@gentoo.org> (2022-07-26)
-# Fails to build with ffmpeg 5, no reverse dependencies, maintainer-needed,
-# and no commits upstream since 2017. Bug #834383. Removal on 2022-08-26.
-media-libs/libgroove
-
# Marek Szuba <marecki@gentoo.org> (2022-07-13)
# Upstream has switched from CMake to hand-crafted Makefiles (yes, TO them),
# which have seriously messed up dependency handling and trigger several