summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-09 10:38:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-09 13:24:49 +0200
commit3281246d92418e152fc5c51ca07c1bbf6e72dcbc (patch)
treeba4c2463d9492bcae456983e1bbb40c9386053b5
parentx11-wm/mutter-40: add patchset with some upstream fixes (diff)
downloadgentoo-3281246d.tar.gz
gentoo-3281246d.tar.bz2
gentoo-3281246d.zip
dev-python/google-auth: Eliminate test-dep on oauth2client
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth/google-auth-2.3.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/google-auth/google-auth-2.3.0.ebuild b/dev-python/google-auth/google-auth-2.3.0.ebuild
index cd44f928efdd..a0d95fea9961 100644
--- a/dev-python/google-auth/google-auth-2.3.0.ebuild
+++ b/dev-python/google-auth/google-auth-2.3.0.ebuild
@@ -33,7 +33,6 @@ BDEPEND="
dev-python/grpcio[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/moto[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pytest-localserver[${PYTHON_USEDEP}]
dev-python/pyu2f[${PYTHON_USEDEP}]
@@ -44,6 +43,12 @@ BDEPEND="
distutils_enable_tests pytest
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die