summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-07 06:05:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-07 06:43:04 +0200
commit32b85f4a73a2cf2af397fe838b36b1aa0b81d2e3 (patch)
treedc0a4dc8b7ddae1fb85dce1ee20bc3ab2041af63
parentdev-python/apsw: Bump to 3.43.1.1 (diff)
downloadgentoo-32b85f4a73a2cf2af397fe838b36b1aa0b81d2e3.tar.gz
gentoo-32b85f4a73a2cf2af397fe838b36b1aa0b81d2e3.tar.bz2
gentoo-32b85f4a73a2cf2af397fe838b36b1aa0b81d2e3.zip
dev-python/annotated-types: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/annotated-types/Manifest1
-rw-r--r--dev-python/annotated-types/annotated-types-0.6.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/annotated-types/Manifest b/dev-python/annotated-types/Manifest
index 49912a423f0c..8828a9e0376d 100644
--- a/dev-python/annotated-types/Manifest
+++ b/dev-python/annotated-types/Manifest
@@ -1 +1,2 @@
DIST annotated_types-0.5.0.tar.gz 13504 BLAKE2B 6c13267b2bdcafabc57e734e3a92133c140ed34560625ed067e01b19f4c8e250b01dacfd5518d0e7283fe469d053a1c1baed173f215231e7303defc3e444667d SHA512 d59c00ff84d510d87149aa9a33deb26e2c3aee98f0f99b63cc0eba83a212c4c1567fcb81370e8bf9add32fd23cc9ea2a5a8692a840d316c44ab7a550bd4349b3
+DIST annotated_types-0.6.0.tar.gz 14670 BLAKE2B 9390abe727f9b7a777e8266e192e032e2f36703c76a60e7fa34dd5517db8129f75e617b67ff88e9f299d10dd3f076d6793bf86e04b6230f2c4df886a8e0719cb SHA512 6b7f6fa23f47758d955822564227173951d6ddd854397b0c996bb6adeadd9caebfab6d193595be17003c1ef0e81a6bd8e20ec8221a70ffa35f9a4414300e788d
diff --git a/dev-python/annotated-types/annotated-types-0.6.0.ebuild b/dev-python/annotated-types/annotated-types-0.6.0.ebuild
new file mode 100644
index 000000000000..f2c2a18d0815
--- /dev/null
+++ b/dev-python/annotated-types/annotated-types-0.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reusable constraint types to use with typing.Annotated"
+HOMEPAGE="
+ https://github.com/annotated-types/annotated-types/
+ https://pypi.org/project/annotated-types/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest