summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-19 14:54:15 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-12-12 22:31:38 +0100
commit32be8e2a61734b15aee9abb1424c41dce5b511d7 (patch)
tree051aab1095e6820b6f51731d6a99375a26a706d8
parentdev-python/stripe: Stabilize 2.62.0 x86, #829013 (diff)
downloadgentoo-32be8e2a61734b15aee9abb1424c41dce5b511d7.tar.gz
gentoo-32be8e2a61734b15aee9abb1424c41dce5b511d7.tar.bz2
gentoo-32be8e2a61734b15aee9abb1424c41dce5b511d7.zip
www-client/firefox: Add USE=system-png
Since Firefox requires patched version of media-libs/libpng and the patches are known to break WebKit, provide the ability to build against vendored libpng in order to make it possible for the users to return to vanilla libpng. See-also: https://gitweb.gentoo.org/sites/projects/council.git/tree/meeting-logs/20211212.txt#n98 Bug: https://bugs.gentoo.org/824834 Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--www-client/firefox/firefox-78.15.0.ebuild6
-rw-r--r--www-client/firefox/firefox-91.3.0.ebuild6
-rw-r--r--www-client/firefox/firefox-93.0.ebuild6
-rw-r--r--www-client/firefox/firefox-94.0.1-r1.ebuild6
-rw-r--r--www-client/firefox/firefox-94.0.2.ebuild6
-rw-r--r--www-client/firefox/firefox-95.0.ebuild6
-rw-r--r--www-client/firefox/metadata.xml2
7 files changed, 20 insertions, 18 deletions
diff --git a/www-client/firefox/firefox-78.15.0.ebuild b/www-client/firefox/firefox-78.15.0.ebuild
index ae8073885f93..cf9e8bd97158 100644
--- a/www-client/firefox/firefox-78.15.0.ebuild
+++ b/www-client/firefox/firefox-78.15.0.ebuild
@@ -64,7 +64,7 @@ LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free geckodriver +gmp-autoupdate
hardened hwaccel jack lto +openh264 pgo pulseaudio screencast selinux
+system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent
- +system-libvpx +system-webp wayland wifi"
+ +system-libvpx system-png +system-webp wayland wifi"
REQUIRED_USE="debug? ( !system-av1 )
screencast? ( wayland )
@@ -131,7 +131,6 @@ CDEPEND="
>=x11-libs/gtk+-3.4.0:3[X]
x11-libs/gdk-pixbuf
>=x11-libs/pango-1.22.0
- >=media-libs/libpng-1.6.35:0=[apng]
>=media-libs/mesa-10.2:*
media-libs/fontconfig
>=media-libs/freetype-2.4.10
@@ -166,6 +165,7 @@ CDEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0=[threads] )
system-libvpx? ( >=media-libs/libvpx-1.8.2:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.35:0=[apng] )
system-webp? ( >=media-libs/libwebp-1.1.0:0= )
wifi? (
kernel_linux? (
@@ -637,7 +637,6 @@ src_configure() {
--with-libclang-path="$(llvm-config --libdir)" \
--with-system-nspr \
--with-system-nss \
- --with-system-png \
--with-system-zlib \
--with-toolchain-prefix="${CHOST}-" \
--with-unsigned-addon-scopes=app,system \
@@ -696,6 +695,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-libevent system-libevent "${SYSROOT}${EPREFIX}/usr"
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-webp
mozconfig_use_enable dbus
diff --git a/www-client/firefox/firefox-91.3.0.ebuild b/www-client/firefox/firefox-91.3.0.ebuild
index 5f04301ca82d..713d7014869a 100644
--- a/www-client/firefox/firefox-91.3.0.ebuild
+++ b/www-client/firefox/firefox-91.3.0.ebuild
@@ -64,7 +64,7 @@ LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
IUSE+=" jack lto +openh264 pgo pulseaudio sndio selinux"
-IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx +system-webp"
+IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx system-png +system-webp"
IUSE+=" wayland wifi"
# Firefox-only IUSE
@@ -131,7 +131,6 @@ CDEPEND="
>=x11-libs/gtk+-3.4.0:3[X]
x11-libs/gdk-pixbuf
>=x11-libs/pango-1.22.0
- >=media-libs/libpng-1.6.35:0=[apng]
>=media-libs/mesa-10.2:*
media-libs/fontconfig
>=media-libs/freetype-2.4.10
@@ -167,6 +166,7 @@ CDEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0=[threads] )
system-libvpx? ( >=media-libs/libvpx-1.8.2:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.35:0=[apng] )
system-webp? ( >=media-libs/libwebp-1.1.0:0= )
wifi? (
kernel_linux? (
@@ -711,7 +711,6 @@ src_configure() {
--with-libclang-path="$(llvm-config --libdir)" \
--with-system-nspr \
--with-system-nss \
- --with-system-png \
--with-system-zlib \
--with-toolchain-prefix="${CHOST}-" \
--with-unsigned-addon-scopes=app,system \
@@ -770,6 +769,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-libevent system-libevent "${SYSROOT}${EPREFIX}/usr"
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-webp
mozconfig_use_enable dbus
diff --git a/www-client/firefox/firefox-93.0.ebuild b/www-client/firefox/firefox-93.0.ebuild
index 0a7fa6f83161..de6db51e039e 100644
--- a/www-client/firefox/firefox-93.0.ebuild
+++ b/www-client/firefox/firefox-93.0.ebuild
@@ -64,7 +64,7 @@ LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free geckodriver +gmp-autoupdate
hardened hwaccel jack lto +openh264 pgo pulseaudio screencast sndio selinux
+system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent
- +system-libvpx +system-webp wayland wifi"
+ +system-libvpx system-png +system-webp wayland wifi"
REQUIRED_USE="debug? ( !system-av1 )
screencast? ( wayland )"
@@ -122,7 +122,6 @@ CDEPEND="
>=x11-libs/gtk+-3.4.0:3[X]
x11-libs/gdk-pixbuf
>=x11-libs/pango-1.22.0
- >=media-libs/libpng-1.6.35:0=[apng]
>=media-libs/mesa-10.2:*
media-libs/fontconfig
>=media-libs/freetype-2.4.10
@@ -156,6 +155,7 @@ CDEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0=[threads] )
system-libvpx? ( >=media-libs/libvpx-1.8.2:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.35:0=[apng] )
system-webp? ( >=media-libs/libwebp-1.1.0:0= )
wifi? (
kernel_linux? (
@@ -637,7 +637,6 @@ src_configure() {
--with-libclang-path="$(llvm-config --libdir)" \
--with-system-nspr \
--with-system-nss \
- --with-system-png \
--with-system-zlib \
--with-toolchain-prefix="${CHOST}-" \
--with-unsigned-addon-scopes=app,system \
@@ -696,6 +695,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-libevent system-libevent "${SYSROOT}${EPREFIX}/usr"
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-webp
mozconfig_use_enable dbus
diff --git a/www-client/firefox/firefox-94.0.1-r1.ebuild b/www-client/firefox/firefox-94.0.1-r1.ebuild
index eb7a24217862..846c8504e466 100644
--- a/www-client/firefox/firefox-94.0.1-r1.ebuild
+++ b/www-client/firefox/firefox-94.0.1-r1.ebuild
@@ -64,7 +64,7 @@ LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
IUSE+=" jack lto +openh264 pgo pulseaudio sndio selinux"
-IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx +system-webp"
+IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx system-png +system-webp"
IUSE+=" wayland wifi"
# Firefox-only IUSE
@@ -131,7 +131,6 @@ CDEPEND="
>=x11-libs/gtk+-3.4.0:3[X]
x11-libs/gdk-pixbuf
>=x11-libs/pango-1.22.0
- >=media-libs/libpng-1.6.35:0=[apng]
>=media-libs/mesa-10.2:*
media-libs/fontconfig
>=media-libs/freetype-2.4.10
@@ -167,6 +166,7 @@ CDEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0=[threads] )
system-libvpx? ( >=media-libs/libvpx-1.8.2:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.35:0=[apng] )
system-webp? ( >=media-libs/libwebp-1.1.0:0= )
wifi? (
kernel_linux? (
@@ -711,7 +711,6 @@ src_configure() {
--with-libclang-path="$(llvm-config --libdir)" \
--with-system-nspr \
--with-system-nss \
- --with-system-png \
--with-system-zlib \
--with-toolchain-prefix="${CHOST}-" \
--with-unsigned-addon-scopes=app,system \
@@ -770,6 +769,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-libevent system-libevent "${SYSROOT}${EPREFIX}/usr"
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-webp
mozconfig_use_enable dbus
diff --git a/www-client/firefox/firefox-94.0.2.ebuild b/www-client/firefox/firefox-94.0.2.ebuild
index eb7a24217862..846c8504e466 100644
--- a/www-client/firefox/firefox-94.0.2.ebuild
+++ b/www-client/firefox/firefox-94.0.2.ebuild
@@ -64,7 +64,7 @@ LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
IUSE+=" jack lto +openh264 pgo pulseaudio sndio selinux"
-IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx +system-webp"
+IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx system-png +system-webp"
IUSE+=" wayland wifi"
# Firefox-only IUSE
@@ -131,7 +131,6 @@ CDEPEND="
>=x11-libs/gtk+-3.4.0:3[X]
x11-libs/gdk-pixbuf
>=x11-libs/pango-1.22.0
- >=media-libs/libpng-1.6.35:0=[apng]
>=media-libs/mesa-10.2:*
media-libs/fontconfig
>=media-libs/freetype-2.4.10
@@ -167,6 +166,7 @@ CDEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0=[threads] )
system-libvpx? ( >=media-libs/libvpx-1.8.2:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.35:0=[apng] )
system-webp? ( >=media-libs/libwebp-1.1.0:0= )
wifi? (
kernel_linux? (
@@ -711,7 +711,6 @@ src_configure() {
--with-libclang-path="$(llvm-config --libdir)" \
--with-system-nspr \
--with-system-nss \
- --with-system-png \
--with-system-zlib \
--with-toolchain-prefix="${CHOST}-" \
--with-unsigned-addon-scopes=app,system \
@@ -770,6 +769,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-libevent system-libevent "${SYSROOT}${EPREFIX}/usr"
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-webp
mozconfig_use_enable dbus
diff --git a/www-client/firefox/firefox-95.0.ebuild b/www-client/firefox/firefox-95.0.ebuild
index 4eff2ddf97e3..e63a3eeb68c3 100644
--- a/www-client/firefox/firefox-95.0.ebuild
+++ b/www-client/firefox/firefox-95.0.ebuild
@@ -64,7 +64,7 @@ LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
IUSE+=" jack lto +openh264 pgo pulseaudio sndio selinux"
-IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx +system-webp"
+IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx system-png +system-webp"
IUSE+=" wayland wifi"
# Firefox-only IUSE
@@ -125,7 +125,6 @@ CDEPEND="
>=x11-libs/gtk+-3.4.0:3[X]
x11-libs/gdk-pixbuf
>=x11-libs/pango-1.22.0
- >=media-libs/libpng-1.6.35:0=[apng]
>=media-libs/mesa-10.2:*
media-libs/fontconfig
>=media-libs/freetype-2.4.10
@@ -161,6 +160,7 @@ CDEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0=[threads] )
system-libvpx? ( >=media-libs/libvpx-1.8.2:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.35:0=[apng] )
system-webp? ( >=media-libs/libwebp-1.1.0:0= )
wifi? (
kernel_linux? (
@@ -706,7 +706,6 @@ src_configure() {
--with-libclang-path="$(llvm-config --libdir)" \
--with-system-nspr \
--with-system-nss \
- --with-system-png \
--with-system-zlib \
--with-toolchain-prefix="${CHOST}-" \
--with-unsigned-addon-scopes=app,system \
@@ -765,6 +764,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-libevent system-libevent "${SYSROOT}${EPREFIX}/usr"
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-webp
mozconfig_use_enable dbus
diff --git a/www-client/firefox/metadata.xml b/www-client/firefox/metadata.xml
index 32fae3878c8b..ac687a3eddcb 100644
--- a/www-client/firefox/metadata.xml
+++ b/www-client/firefox/metadata.xml
@@ -32,6 +32,8 @@
instead of bundled.</flag>
<flag name="system-libvpx">Use the system-wide <pkg>media-libs/libvpx</pkg>
instead of bundled.</flag>
+ <flag name="system-png">Use the system-wide <pkg>media-libs/libpng</pkg>
+ instead of bundled (requires APNG patches).</flag>
<flag name="system-webp">Use the system-wide <pkg>media-libs/libwebp</pkg>
instead of bundled.</flag>
</use>