summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2024-05-17 09:54:45 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2024-05-17 09:57:05 +0300
commit32e720fc4ab6c8c11c86f1518cad6b0cb77d4dbf (patch)
treea85dc3ea0954ad0b6039ff4ecd85383e1c5dc645
parentdev-libs/tree-sitter-go: Stabilize 0.21.0 amd64, #932022 (diff)
downloadgentoo-32e720fc4ab6c8c11c86f1518cad6b0cb77d4dbf.tar.gz
gentoo-32e720fc4ab6c8c11c86f1518cad6b0cb77d4dbf.tar.bz2
gentoo-32e720fc4ab6c8c11c86f1518cad6b0cb77d4dbf.zip
sci-chemistry/modeller: add 10.5, drop 9.25
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
-rw-r--r--sci-chemistry/modeller/Manifest2
-rw-r--r--sci-chemistry/modeller/files/modeller-10.5-fix-except.patch29
-rw-r--r--sci-chemistry/modeller/modeller-10.5.ebuild (renamed from sci-chemistry/modeller/modeller-9.25.ebuild)15
3 files changed, 37 insertions, 9 deletions
diff --git a/sci-chemistry/modeller/Manifest b/sci-chemistry/modeller/Manifest
index e3d097b4b75d..7f12b0817212 100644
--- a/sci-chemistry/modeller/Manifest
+++ b/sci-chemistry/modeller/Manifest
@@ -1 +1 @@
-DIST modeller-9.25.tar.gz 44820658 BLAKE2B b3e8a3cc8cc70689a25bc5ed2eee294d67bef8eea9ed4b64d41aba3a27c0bc428ae58e74d734da0eaab7e4fabb213d098b9ba66b9569557159ac7d4a58244b0a SHA512 93f273aba0ec0f884cde5bbcc24769a09386bfc6bf1744d80001e41924b1a682225ba3c554fb9898ef3bfd1fd8451f9458bb92431b20f2f51b01781e79686c91
+DIST modeller-10.5.tar.gz 38272541 BLAKE2B 9c71a9f1e4c34c91852db73ebf86f71cf355217d6889566ff6840dc6874d4906b989a36f3dd642ba4e4d1fe671c1a15753a33e7fabb53adc9182c76fe4fdb6c4 SHA512 666c5367a14084438c96b68ba0779ebd97ca831a4a6538f66e54b63657c8e13b85931c2de8300311f1df7d02907b2ec61f27f95b0704f2c6a313b6baee56febc
diff --git a/sci-chemistry/modeller/files/modeller-10.5-fix-except.patch b/sci-chemistry/modeller/files/modeller-10.5-fix-except.patch
new file mode 100644
index 000000000000..f480a8229bf9
--- /dev/null
+++ b/sci-chemistry/modeller/files/modeller-10.5-fix-except.patch
@@ -0,0 +1,29 @@
+--- a/modlib/modeller/top_interpreter/__init__.py 2024-03-27 15:52:04.005550025 +0300
++++ b/modlib/modeller/top_interpreter/__init__.py 2024-03-27 15:54:00.776897686 +0300
+@@ -65,7 +65,7 @@
+ if len(line) > 0:
+ try:
+ self._parse_top_ini_line(line.split(None, 4), vars)
+- except TypeError, detail: # noqa: E999
++ except (TypeError, detail): # noqa: E999
+ mod_log_write("read_top__E> " + str(detail))
+ mod_log_write(" top.ini line: " + line)
+ raise
+@@ -115,7 +115,7 @@
+ try:
+ fh = self._open_include_file(
+ self.variables['include_file'])
+- except IOError, detail:
++ except (IOError, detail):
+ mod_log_write("runlines__E> " + str(detail))
+ mod_log_write(" TOP Command line: " + line)
+ raise
+@@ -162,7 +162,7 @@
+ indxca = self._run_top_cmd(cmd, indxca, lines, callstack,
+ subrout)
+ _modeller.mod_top_post()
+- except (IndexError, SyntaxError, TypeError), detail:
++ except (IndexError, SyntaxError, TypeError, detail):
+ mod_log_write("runlines__E> " + str(detail))
+ mod_log_write(" TOP Command line: " + line)
+ raise
diff --git a/sci-chemistry/modeller/modeller-9.25.ebuild b/sci-chemistry/modeller/modeller-10.5.ebuild
index 1401279be237..80718ec876c8 100644
--- a/sci-chemistry/modeller/modeller-9.25.ebuild
+++ b/sci-chemistry/modeller/modeller-10.5.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
inherit distutils-r1
@@ -13,14 +14,15 @@ HOMEPAGE="https://salilab.org/modeller/"
SRC_URI="https://salilab.org/${PN}/${PV}/${P}.tar.gz"
LICENSE="modeller"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples"
-SLOT="0"
RESTRICT="mirror"
DEPEND=">=dev-lang/swig-1.3"
-RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-fix-except.patch" )
INPATH="${EPREFIX}"/opt/modeller${ver}
@@ -40,8 +42,6 @@ pkg_setup() {
python_prepare_all() {
sed "s:i386-intel8:${EXECTYPE}:g" -i src/swig/setup.py || die
rm -rf modlib/modeller/python_library || die
- sed -i '1 i\#!/usr/bin/python' bin/modslave.py || die
- 2to3 -w -n modlib/modeller || die
distutils-r1_python_prepare_all
}
@@ -77,7 +77,6 @@ python_install_all() {
exeinto ${INPATH}/bin
doexe bin/{modscript,mod${PV}_${EXECTYPE}} "${T}"/modpy.sh
- python_foreach_impl python_doscript bin/modslave.py
dosym ${INPATH}/bin/modscript /opt/bin/mod${PV}
dosym ${INPATH}/bin/modpy.sh /opt/bin/modpy.sh