summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-19 04:42:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-19 05:16:35 +0200
commit32e7e2da6d52259e09dafc3fdbc4b49c1d30e050 (patch)
tree6be41cc1567e31b748e84f31a62d8f44d89336cd
parentdev-python/botocore: Bump to 1.31.50 (diff)
downloadgentoo-32e7e2da.tar.gz
gentoo-32e7e2da.tar.bz2
gentoo-32e7e2da.zip
dev-python/boto3: Bump to 1.28.50
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.50.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1d5d824563cd..3530a723fbeb 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -12,3 +12,4 @@ DIST boto3-1.28.46.gh.tar.gz 699277 BLAKE2B 7bc3a739cbb40b56c7b993132571add6d77f
DIST boto3-1.28.47.gh.tar.gz 699978 BLAKE2B 056a6c4ac0d94dd147cf1a0e438f9947b2a0bf9f608b5317fe71f58192003cd6de819acc090067cc86124be6ead967bf8cc15ac9061008a15e57cb4259145bb8 SHA512 e0ad5c30677a6c04206a1845ac1cb19a91789885de7ca2cfbac70743e54f8d3254471672c560dc0b97f3d46b6366455521cb78d1c300428ff01f2fdfa1da7ff6
DIST boto3-1.28.48.gh.tar.gz 700213 BLAKE2B 3ddb02067fee032d3d5e493849936b854130def109f46806fe826845da1daa681920448d96658910ec3064d576de1fe6055d514345cbe88d548278c16c2a28a9 SHA512 b561b0631af566a82495d97ba9c4dc58183361868042b70c353004c58c3cfc38c3496eb5a4d387e5272b76f479a7f101676fc3a9b6306d203e5122bde0091e98
DIST boto3-1.28.49.gh.tar.gz 700443 BLAKE2B 7c76e0ee6d6de1f7a67534a49e54092a564d419f9fc18b25375d2416af07987039bf864e0c2a996d5b64c3f9207dcd50da6ee5b0e2bf606e453d7841ddd6f7d4 SHA512 597debebb60c33bdf2bcc485bbf9ab7c433a5750b71708ffcd2847b6b21199c1c598edeb35e236f6b7feca3f762b5d62f9637e00876b7c0629baae50e7f132c9
+DIST boto3-1.28.50.gh.tar.gz 700837 BLAKE2B 57dd760ef175b16a9aebfa86d39a6529809f22101a1cab3334f239d23ef6f865fa573dcf38e5aab66aee5ea3c448c91c21bff78835a3d07de8508397c5e809fa SHA512 8b31a6012b398c067b927ac4c428fa61f881a88afb865d88a407d9c06fc69a402778198afa7f39ee158f61e952956f18f6f32edbf076098eda5431e92c06f5cc
diff --git a/dev-python/boto3/boto3-1.28.50.ebuild b/dev-python/boto3/boto3-1.28.50.ebuild
new file mode 100644
index 000000000000..90e1b0ce7382
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.50.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}