summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-21 23:18:29 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-22 09:29:27 +0200
commit32ec7cd438905d9c6f49d8ad16cfcc88d852e731 (patch)
tree31726c76aba9dd4592cec3a37cb74f06152e48a5
parentdev-ruby/sanitize: add 4.3.0 (diff)
downloadgentoo-32ec7cd4.tar.gz
gentoo-32ec7cd4.tar.bz2
gentoo-32ec7cd4.zip
sci-biology/tophat: Allow for compiling with GCC 6
Gentoo-bug: 594544 Package-Manager: portage-2.3.1
-rw-r--r--sci-biology/tophat/files/tophat-2.1.1-fix-c++14.patch14
-rw-r--r--sci-biology/tophat/tophat-2.1.1-r1.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/sci-biology/tophat/files/tophat-2.1.1-fix-c++14.patch b/sci-biology/tophat/files/tophat-2.1.1-fix-c++14.patch
new file mode 100644
index 000000000000..e8168bb91438
--- /dev/null
+++ b/sci-biology/tophat/files/tophat-2.1.1-fix-c++14.patch
@@ -0,0 +1,14 @@
+Fix building with C++14, which errors out due to broken perfect forwarding signature.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=594544
+
+--- a/src/tophat_reports.cpp
++++ b/src/tophat_reports.cpp
+@@ -2705,7 +2705,7 @@
+ junction_stat.gtf_match = true;
+ junction_stat.accepted = true;
+
+- gtf_junctions.insert(make_pair<Junction, JunctionStats>(Junction(ref_id, left_coord, right_coord, antisense), junction_stat));
++ gtf_junctions.insert(make_pair(Junction(ref_id, left_coord, right_coord, antisense), junction_stat));
+ }
+ }
+ fprintf(stderr, "Loaded %d GFF junctions from %s.\n", (int)(gtf_junctions.size()), gtf_juncs.c_str());
diff --git a/sci-biology/tophat/tophat-2.1.1-r1.ebuild b/sci-biology/tophat/tophat-2.1.1-r1.ebuild
index a8501758f5d9..6c6690a7a86e 100644
--- a/sci-biology/tophat/tophat-2.1.1-r1.ebuild
+++ b/sci-biology/tophat/tophat-2.1.1-r1.ebuild
@@ -28,6 +28,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${P}-unbundle-seqan-samtools.patch"
+ "${FILESDIR}/${P}-fix-c++14.patch"
)
src_prepare() {