summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-09 13:12:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-09 14:29:21 +0200
commit32f13dc9e4d6a8643ef98cc5f4fb6b45532dd7fd (patch)
tree6aee4e067be004ce0eb8f4c84b56039c1a35b090
parentpackage.mask: Last rite next py2 batch (diff)
downloadgentoo-32f13dc9.tar.gz
gentoo-32f13dc9.tar.bz2
gentoo-32f13dc9.zip
app-misc/g15daemon: Revbumps / ebuild overhauls
- EAPI-7 bump - Added workaround for successful build with gcc-10 (#706712) - Fixed default config (#481454) - Fixed docdir - Attempt to fix direct call of CC (#729294) - Removed bashisms from configure Bug: https://bugs.gentoo.org/729294 Bug: https://bugs.gentoo.org/741382 Closes: https://bugs.gentoo.org/481454 Closes: https://bugs.gentoo.org/706712 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.2.7.confd2
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3-avoid_bashisms.patch20
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3-docdir.patch11
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch4
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch5
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.9.5.3-overflow-fix.patch4
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r14.ebuild (renamed from app-misc/g15daemon/g15daemon-1.9.5.3-r13.ebuild)48
-rw-r--r--app-misc/g15daemon/g15daemon-1.9.5.3-r21.ebuild47
-rw-r--r--app-misc/g15daemon/g15daemon-9999.ebuild54
9 files changed, 119 insertions, 76 deletions
diff --git a/app-misc/g15daemon/files/g15daemon-1.2.7.confd b/app-misc/g15daemon/files/g15daemon-1.2.7.confd
index 08ea97f49763..5ce5392b93b1 100644
--- a/app-misc/g15daemon/files/g15daemon-1.2.7.confd
+++ b/app-misc/g15daemon/files/g15daemon-1.2.7.confd
@@ -2,7 +2,7 @@
# Key to switch the client-screens. Default is the MR key,
# Set to "yes" to use L1 key instead (black round key below the LCD, above the multimedia keys).
-CLIENT_SWITCH_L1="no"
+CLIENT_SWITCH_L1="yes"
# Set to "yes" to switch off the lcd backlight when stopping g15daemon.
BACKLIGHT_OFF="no"
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3-avoid_bashisms.patch b/app-misc/g15daemon/files/g15daemon-1.9.5.3-avoid_bashisms.patch
new file mode 100644
index 000000000000..194d68eefeea
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3-avoid_bashisms.patch
@@ -0,0 +1,20 @@
+--- g15daemon-1.9.5.3/configure.in
++++ g15daemon-1.9.5.3/configure.in
+@@ -53,7 +53,7 @@
+ AC_ARG_ENABLE([--disable-uinput],[ --disable-uinput do not build linux uinput plugin (default: autodetect)])
+
+ if test "x$enable_uinput" != "xno"; then
+- if test "x$have_linux_uinput_h" == "xyes"; then
++ if test "x$have_linux_uinput_h" = "xyes"; then
+ #if HAVE_LINUX_UINPUT_H
+ dnl check for uinput.h version 2.4 or 2.6 ?
+ AC_CHECK_MEMBER([struct uinput_user_dev.id],
+@@ -110,7 +110,7 @@
+ AM_CONDITIONAL(UINPUT_INTERFACE_PLUGIN, [test x$uinput = xtrue])
+
+ dnl Some versions of libusb do not honour timeout and block. Suns' version is one of them.
+-if test "x$libusb_blocks" == "xtrue"; then
++if test "x$libusb_blocks" = "xtrue"; then
+ AC_DEFINE([LIBUSB_BLOCKS], [1],[Define if libusb implementation blocks on read or write])
+ fi
+
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3-docdir.patch b/app-misc/g15daemon/files/g15daemon-1.9.5.3-docdir.patch
new file mode 100644
index 000000000000..9c76e4cbc6aa
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3-docdir.patch
@@ -0,0 +1,11 @@
+--- g15daemon-1.9.5.3/Makefile.am
++++ g15daemon-1.9.5.3/Makefile.am
+@@ -5,7 +5,7 @@
+
+ EXTRA_DIST = debian contrib Documentation lang-bindings patches rpm README.usage FAQ LICENSE images README.Linux README.FreeBSD README.Solaris
+
+-docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
++docdir = @docdir@
+ doc_DATA = FAQ README.usage README ChangeLog TODO AUTHORS NEWS LICENSE README.Linux README.FreeBSD README.Solaris
+
+ man1_MANS = $(top_srcdir)/Documentation/g15daemon.1
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch b/app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch
index b475f1d58d69..d4a5381992e1 100644
--- a/app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3-forgotten-open-mode.patch
@@ -1,5 +1,5 @@
---- ./g15daemon-1.9.5.3/g15daemon/utility_funcs.c 2008-01-26 06:02:07.000000000 +0100
-+++ ./g15daemon-1.9.5.3/g15daemon/utility_funcs.c 2009-02-01 17:00:55.203009264 +0100
+--- g15daemon-1.9.5.3/g15daemon/utility_funcs.c
++++ g15daemon-1.9.5.3/g15daemon/utility_funcs.c
@@ -356,7 +356,7 @@
config_items_t * item=NULL;
char line[1024];
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch b/app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch
index e00836766795..a53001f1932d 100644
--- a/app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3-g510-keys.patch
@@ -1,8 +1,7 @@
From https://sourceforge.net/tracker/?func=detail&aid=3152167&group_id=167869&atid=844658
-diff -aNru trunk/g15daemon-wip/plugins/g15_plugin_uinput.c mod/g15daemon-wip/plugins/g15_plugin_uinput.c
---- trunk/g15daemon-wip/plugins/g15_plugin_uinput.c 2011-06-26 06:50:50.000000000 +0000
-+++ mod/g15daemon-wip/plugins/g15_plugin_uinput.c 2011-06-26 06:51:42.000000000 +0000
+--- g15daemon-wip/plugins/g15_plugin_uinput.c
++++ g15daemon-wip/plugins/g15_plugin_uinput.c
@@ -164,146 +164,195 @@
static void g15_process_keys(g15daemon_t *masterlist, unsigned int currentkeys, unsigned int lastkeys)
diff --git a/app-misc/g15daemon/files/g15daemon-1.9.5.3-overflow-fix.patch b/app-misc/g15daemon/files/g15daemon-1.9.5.3-overflow-fix.patch
index 71cbf914d839..07bb68601d76 100644
--- a/app-misc/g15daemon/files/g15daemon-1.9.5.3-overflow-fix.patch
+++ b/app-misc/g15daemon/files/g15daemon-1.9.5.3-overflow-fix.patch
@@ -1,5 +1,5 @@
---- ./g15daemon-1.9.5.3/libg15daemon_client/g15daemon_net.c 2008-01-25 05:45:05.000000000 +0100
-+++ ./g15daemon-1.9.5.3/libg15daemon_client/g15daemon_net.c 2011-02-14 22:51:55.203009264 +0100
+--- g15daemon-1.9.5.3/libg15daemon_client/g15daemon_net.c
++++ g15daemon-1.9.5.3/libg15daemon_client/g15daemon_net.c
@@ -217,7 +217,7 @@
if(poll(pfd,1,100)>0){
if(pfd[0].revents & POLLPRI && !(pfd[0].revents & POLLERR || pfd[0].revents & POLLHUP || pfd[0].revents & POLLNVAL)) {
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3-r13.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r14.ebuild
index 9351249d7a8c..407950bcbb25 100644
--- a/app-misc/g15daemon/g15daemon-1.9.5.3-r13.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r14.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
GENTOO_DEPEND_ON_PERL="no"
-inherit eutils linux-info perl-module base
+inherit autotools flag-o-matic linux-info perl-module toolchain-funcs udev
DESCRIPTION="Takes control of the G15 keyboard, through the linux kernel uinput device driver"
HOMEPAGE="https://sourceforge.net/projects/g15daemon/"
@@ -29,14 +29,17 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-forgotten-open-mode.patch"
"${FILESDIR}/${P}-overflow-fix.patch"
+ "${FILESDIR}/${P}-docdir.patch"
+ "${FILESDIR}/${P}-avoid_bashisms.patch"
)
+
uinput_check() {
ebegin "Checking for uinput support"
local rc=1
linux_config_exists && linux_chkconfig_present INPUT_UINPUT
rc=$?
- if [[ $rc -ne 0 ]] ; then
+ if [[ ${rc} -ne 0 ]] ; then
eerror "To use g15daemon, you need to compile your kernel with uinput support."
eerror "Please enable uinput support in your kernel config, found at:"
eerror
@@ -48,36 +51,40 @@ uinput_check() {
}
pkg_setup() {
+ export CC="$(tc-getCC)" #729294
+
linux-info_pkg_setup
uinput_check
}
src_unpack() {
unpack ${A}
- if use perl; then
+ if use perl ; then
unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
fi
}
src_prepare() {
- if use perl; then
+ if use perl ; then
perl-module_src_prepare
sed -i \
-e '1i#!/usr/bin/perl' \
- "${S}"/contrib/testbindings.pl
+ "${S}"/contrib/testbindings.pl || die
else
# perl-module_src_prepare always calls base_src_prepare
- base_src_prepare
+ default
fi
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable static-libs static)
+ append-cflags -fcommon #706712
+
+ econf $(use_enable static-libs static)
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
perl-module_src_configure
fi
}
@@ -85,8 +92,8 @@ src_configure() {
src_compile() {
default
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
perl-module_src_compile
fi
}
@@ -94,23 +101,22 @@ src_compile() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}" -type f -name '*.la' -delete || die
# remove odd docs installed my make
- rm "${ED}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+ rm "${ED}"/usr/share/doc/${PF}/README.usage || die
insinto /usr/share/${PN}/contrib
doins contrib/xmodmaprc
doins contrib/xmodmap.sh
- if use perl; then
+ if use perl ; then
doins contrib/testbindings.pl
fi
newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
newinitd "${FILESDIR}/${PN}-1.9.5.3.initd" ${PN}
dobin "${FILESDIR}/g15daemon-hotplug"
- insinto /lib/udev/rules.d
- doins "${FILESDIR}/99-g15daemon.rules"
+ udev_dorules "${FILESDIR}/99-g15daemon.rules"
insinto /etc
doins "${FILESDIR}"/g15daemon.conf
@@ -119,9 +125,9 @@ src_install() {
exeinto /usr/lib/pm-utils/sleep.d
doexe "${FILESDIR}"/20g15daemon
- if use perl; then
+ if use perl ; then
ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
+ cd "${WORKDIR}/G15Daemon-0.2" || die
docinto perl
perl-module_src_install
fi
diff --git a/app-misc/g15daemon/g15daemon-1.9.5.3-r21.ebuild b/app-misc/g15daemon/g15daemon-1.9.5.3-r21.ebuild
index df58caed05fc..7955e66c251f 100644
--- a/app-misc/g15daemon/g15daemon-1.9.5.3-r21.ebuild
+++ b/app-misc/g15daemon/g15daemon-1.9.5.3-r21.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
GENTOO_DEPEND_ON_PERL="no"
-inherit eutils linux-info perl-module base
+inherit autotools flag-o-matic linux-info perl-module toolchain-funcs udev
DESCRIPTION="Takes control of the G15 keyboard, through the linux kernel uinput device driver"
HOMEPAGE="https://sourceforge.net/projects/g15daemon/"
@@ -30,6 +30,8 @@ PATCHES=(
"${FILESDIR}/${P}-forgotten-open-mode.patch"
"${FILESDIR}/${P}-overflow-fix.patch"
"${FILESDIR}/${P}-g510-keys.patch"
+ "${FILESDIR}/${P}-docdir.patch"
+ "${FILESDIR}/${P}-avoid_bashisms.patch"
)
uinput_check() {
@@ -38,7 +40,7 @@ uinput_check() {
linux_config_exists && linux_chkconfig_present INPUT_UINPUT
rc=$?
- if [[ $rc -ne 0 ]] ; then
+ if [[ ${rc} -ne 0 ]] ; then
eerror "To use g15daemon, you need to compile your kernel with uinput support."
eerror "Please enable uinput support in your kernel config, found at:"
eerror
@@ -50,36 +52,40 @@ uinput_check() {
}
pkg_setup() {
+ export CC="$(tc-getCC)" #729294
+
linux-info_pkg_setup
uinput_check
}
src_unpack() {
unpack ${A}
- if use perl; then
+ if use perl ; then
unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
fi
}
src_prepare() {
- if use perl; then
+ if use perl ; then
perl-module_src_prepare
sed -i \
-e '1i#!/usr/bin/perl' \
- "${S}"/contrib/testbindings.pl
+ "${S}"/contrib/testbindings.pl || die
else
# perl-module_src_prepare always calls base_src_prepare
- base_src_prepare
+ default
fi
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable static-libs static)
+ append-cflags -fcommon #706712
+
+ econf $(use_enable static-libs static)
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
perl-module_src_configure
fi
}
@@ -87,8 +93,8 @@ src_configure() {
src_compile() {
default
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
perl-module_src_compile
fi
}
@@ -96,23 +102,22 @@ src_compile() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}" -type f -name '*.la' -delete || die
# remove odd docs installed my make
- rm "${ED}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+ rm "${ED}"/usr/share/doc/${PF}/README.usage || die
insinto /usr/share/${PN}/contrib
doins contrib/xmodmaprc
doins contrib/xmodmap.sh
- if use perl; then
+ if use perl ; then
doins contrib/testbindings.pl
fi
newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
newinitd "${FILESDIR}/${PN}-1.9.5.3.initd" ${PN}
dobin "${FILESDIR}/g15daemon-hotplug"
- insinto /lib/udev/rules.d
- doins "${FILESDIR}/99-g15daemon.rules"
+ udev_dorules "${FILESDIR}/99-g15daemon.rules"
insinto /etc
doins "${FILESDIR}"/g15daemon.conf
@@ -121,9 +126,9 @@ src_install() {
exeinto /usr/lib/pm-utils/sleep.d
doexe "${FILESDIR}"/20g15daemon
- if use perl; then
+ if use perl ; then
ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
+ cd "${WORKDIR}/G15Daemon-0.2" || die
docinto perl
perl-module_src_install
fi
diff --git a/app-misc/g15daemon/g15daemon-9999.ebuild b/app-misc/g15daemon/g15daemon-9999.ebuild
index c7300da76d08..23fb3430ee40 100644
--- a/app-misc/g15daemon/g15daemon-9999.ebuild
+++ b/app-misc/g15daemon/g15daemon-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
GENTOO_DEPEND_ON_PERL="no"
ESVN_PROJECT=${PN}/trunk
ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk/${PN}-wip"
-inherit eutils linux-info perl-module base subversion autotools
+inherit autotools flag-o-matic linux-info perl-module subversion toolchain-funcs udev
DESCRIPTION="Takes control of the G15 keyboard, through the linux kernel uinput device driver"
HOMEPAGE="https://sourceforge.net/projects/g15daemon/"
@@ -30,9 +30,9 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-1.9.5.3-g510-keys.patch"
+ "${FILESDIR}/${PN}-1.9.5.3-docdir.patch"
+ "${FILESDIR}/${PN}-1.9.5.3-avoid_bashisms.patch"
)
-# "${FILESDIR}/${PN}-1.9.5.3-forgotten-open-mode.patch"
-# "${FILESDIR}/${PN}-1.9.5.3-overflow-fix.patch"
uinput_check() {
ebegin "Checking for uinput support"
@@ -40,7 +40,7 @@ uinput_check() {
linux_config_exists && linux_chkconfig_present INPUT_UINPUT
rc=$?
- if [[ $rc -ne 0 ]] ; then
+ if [[ ${rc} -ne 0 ]] ; then
eerror "To use g15daemon, you need to compile your kernel with uinput support."
eerror "Please enable uinput support in your kernel config, found at:"
eerror
@@ -52,46 +52,49 @@ uinput_check() {
}
pkg_setup() {
+ export CC="$(tc-getCC)" #729294
+
linux-info_pkg_setup
uinput_check
}
src_unpack() {
- if [[ ${PV} = *9999* ]]; then
+ if [[ ${PV} = *9999* ]] ; then
subversion_src_unpack
else
unpack ${A}
fi
- if use perl; then
+ if use perl ; then
unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
fi
}
src_prepare() {
- if [[ ${PV} = *9999* ]]; then
+ if [[ ${PV} = *9999* ]] ; then
subversion_wc_info
fi
- if use perl; then
+ if use perl ; then
perl-module_src_prepare
sed -i \
-e '1i#!/usr/bin/perl' \
- "${S}"/contrib/testbindings.pl
+ "${S}"/contrib/testbindings.pl || die
else
# perl-module_src_prepare always calls base_src_prepare
- base_src_prepare
+ default
fi
- if [[ ${PV} = *9999* ]]; then
+ if [[ ${PV} = *9999* ]] ; then
+ mv configure.{in,ac} || die
eautoreconf
fi
}
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable static-libs static)
+ append-cflags -fcommon #706712
+
+ econf $(use_enable static-libs static)
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
perl-module_src_configure
fi
}
@@ -99,8 +102,8 @@ src_configure() {
src_compile() {
default
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
perl-module_src_compile
fi
}
@@ -108,23 +111,22 @@ src_compile() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}" -type f -name '*.la' -delete || die
# remove odd docs installed my make
- rm "${ED}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+ rm "${ED}"/usr/share/doc/${PF}/README.usage || die
insinto /usr/share/${PN}/contrib
doins contrib/xmodmaprc
doins contrib/xmodmap.sh
- if use perl; then
+ if use perl ; then
doins contrib/testbindings.pl
fi
newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
newinitd "${FILESDIR}/${PN}-1.9.5.3.initd" ${PN}
dobin "${FILESDIR}/g15daemon-hotplug"
- insinto /lib/udev/rules.d
- doins "${FILESDIR}/99-g15daemon.rules"
+ udev_dorules "${FILESDIR}/99-g15daemon.rules"
insinto /etc
doins "${FILESDIR}"/g15daemon.conf
@@ -133,9 +135,9 @@ src_install() {
exeinto /usr/lib/pm-utils/sleep.d
doexe "${FILESDIR}"/20g15daemon
- if use perl; then
+ if use perl ; then
ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
+ cd "${WORKDIR}/G15Daemon-0.2" || die
docinto perl
perl-module_src_install
fi