summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-25 11:22:16 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-25 11:22:52 +0100
commit32f82369d3502a14374795cdf260fe40e933c7cd (patch)
treedf3577c72b238d1dd5ddda4893bb0ef6bee643f2
parentdev-ruby/globalid: add ruby30 (diff)
downloadgentoo-32f82369d3502a14374795cdf260fe40e933c7cd.tar.gz
gentoo-32f82369d3502a14374795cdf260fe40e933c7cd.tar.bz2
gentoo-32f82369d3502a14374795cdf260fe40e933c7cd.zip
dev-ruby/activejob: add ruby30
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/activejob/activejob-7.0.2.3-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/activejob/activejob-7.0.2.3-r1.ebuild b/dev-ruby/activejob/activejob-7.0.2.3-r1.ebuild
new file mode 100644
index 000000000000..250ee550689d
--- /dev/null
+++ b/dev-ruby/activejob/activejob-7.0.2.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.6
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
+ -e 's/delayed_job//' Rakefile || die
+ sed -i -e '/SneakersAdapter/ s:^:#:' test/cases/exceptions_test.rb || die
+ rm -f test/cases/delayed_job_adapter_test.rb || die
+}