summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-29 06:57:41 +0100
committerSam James <sam@gentoo.org>2021-10-29 06:58:23 +0100
commit32fc93f4c6d277ba025266fe97adc91be4eaf2b6 (patch)
tree4d5ce72e76453723b03b77e4948d58d83cf498f8
parentapp-text/calibre: Respect CFLAGS and LDFLAGS (diff)
downloadgentoo-32fc93f4c6d277ba025266fe97adc91be4eaf2b6.tar.gz
gentoo-32fc93f4c6d277ba025266fe97adc91be4eaf2b6.tar.bz2
gentoo-32fc93f4c6d277ba025266fe97adc91be4eaf2b6.zip
app-editors/vim: skip flaky/hanging tests
Closes: https://bugs.gentoo.org/742710 Closes: https://bugs.gentoo.org/616680 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim/vim-8.2.3428-r1.ebuild14
-rw-r--r--app-editors/vim/vim-9999.ebuild14
2 files changed, 28 insertions, 0 deletions
diff --git a/app-editors/vim/vim-8.2.3428-r1.ebuild b/app-editors/vim/vim-8.2.3428-r1.ebuild
index d15fa2f9dcc8..0da725445590 100644
--- a/app-editors/vim/vim-8.2.3428-r1.ebuild
+++ b/app-editors/vim/vim-8.2.3428-r1.ebuild
@@ -270,6 +270,20 @@ src_test() {
# Don't let vim talk to X
unset DISPLAY
+ # See https://github.com/vim/vim/blob/f08b0eb8691ff09f98bc4beef986ece1c521655f/src/testdir/runtest.vim#L5
+ # for more information on test variables we can use.
+ # Note that certain variables need vim-compatible regex (not PCRE), see e.g.
+ # http://www.softpanorama.org/Editors/Vimorama/vim_regular_expressions.shtml.
+ #
+ # Skipped tests:
+ # - Test_expand_star_star
+ # Hangs because of a recursive symlink in /usr/include/nodejs (bug #616680)
+ # - Test_exrc
+ # Looks in wrong location? (bug #742710)
+ # - Test_job_tty_in_out
+ # Fragile and depends on TERM(?)
+ export TEST_SKIP_PAT='\(Test_expand_star_star\|Test_exrc\|Test_job_tty_in_out\)'
+
emake -j1 -C src/testdir nongui
}
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index d15fa2f9dcc8..0da725445590 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -270,6 +270,20 @@ src_test() {
# Don't let vim talk to X
unset DISPLAY
+ # See https://github.com/vim/vim/blob/f08b0eb8691ff09f98bc4beef986ece1c521655f/src/testdir/runtest.vim#L5
+ # for more information on test variables we can use.
+ # Note that certain variables need vim-compatible regex (not PCRE), see e.g.
+ # http://www.softpanorama.org/Editors/Vimorama/vim_regular_expressions.shtml.
+ #
+ # Skipped tests:
+ # - Test_expand_star_star
+ # Hangs because of a recursive symlink in /usr/include/nodejs (bug #616680)
+ # - Test_exrc
+ # Looks in wrong location? (bug #742710)
+ # - Test_job_tty_in_out
+ # Fragile and depends on TERM(?)
+ export TEST_SKIP_PAT='\(Test_expand_star_star\|Test_exrc\|Test_job_tty_in_out\)'
+
emake -j1 -C src/testdir nongui
}