summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-10-06 02:27:50 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-10-06 03:32:18 +0300
commit32fff68860e031a1fef29749447fecd7d07aa2a3 (patch)
tree7b9da36170760e5da57be0256eaafbbdd4255259
parentapp-crypt/gnupg: eapi bump (diff)
downloadgentoo-32fff688.tar.gz
gentoo-32fff688.tar.bz2
gentoo-32fff688.zip
net-libs/gnutls: support cross-compile
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--net-libs/gnutls/gnutls-3.5.19-r1.ebuild14
-rw-r--r--net-libs/gnutls/gnutls-3.6.3.ebuild14
2 files changed, 12 insertions, 16 deletions
diff --git a/net-libs/gnutls/gnutls-3.5.19-r1.ebuild b/net-libs/gnutls/gnutls-3.5.19-r1.ebuild
index 1635d976bdf4..21b4a74b0dc1 100644
--- a/net-libs/gnutls/gnutls-3.5.19-r1.ebuild
+++ b/net-libs/gnutls/gnutls-3.5.19-r1.ebuild
@@ -34,11 +34,11 @@ DEPEND="${RDEPEND}
test? (
seccomp? ( sys-libs/libseccomp )
)"
-BDEPEND=">=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- tools? ( sys-devel/autogen )
- valgrind? ( dev-util/valgrind )
+BDEPEND=">=virtual/pkgconfig-0-r1
doc? ( dev-util/gtk-doc )
nls? ( sys-devel/gettext )
+ tools? ( sys-devel/autogen )
+ valgrind? ( dev-util/valgrind )
test-full? (
app-crypt/dieharder
app-misc/datefudge
@@ -79,10 +79,6 @@ src_prepare() {
multilib_src_configure() {
LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
- # remove magic of library detection
- # bug#438222
- local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
-
# TPM needs to be tested before being enabled
libconf+=( --without-tpm )
@@ -117,9 +113,11 @@ multilib_src_configure() {
$(use_with idn) \
$(use_with pkcs11 p11-kit) \
$(use_with zlib) \
+ --disable-rpath \
--with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
--without-included-libtasn1 \
- "${libconf[@]}"
+ "${libconf[@]}" \
+ $("${S}/configure" --help | grep -- --with-.*-prefix | sed -e 's/prefix.*/prefix/' -e "s#\$#=${EROOT}/usr#")
}
multilib_src_install_all() {
diff --git a/net-libs/gnutls/gnutls-3.6.3.ebuild b/net-libs/gnutls/gnutls-3.6.3.ebuild
index fefc8766f6af..92679e621dc4 100644
--- a/net-libs/gnutls/gnutls-3.6.3.ebuild
+++ b/net-libs/gnutls/gnutls-3.6.3.ebuild
@@ -33,11 +33,11 @@ DEPEND="${RDEPEND}
test? (
seccomp? ( sys-libs/libseccomp )
)"
-BDEPEND=">=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- tools? ( sys-devel/autogen )
- valgrind? ( dev-util/valgrind )
+BDEPEND=">=virtual/pkgconfig-0-r1
doc? ( dev-util/gtk-doc )
nls? ( sys-devel/gettext )
+ tools? ( sys-devel/autogen )
+ valgrind? ( dev-util/valgrind )
test-full? (
app-crypt/dieharder
>=app-misc/datefudge-1.22
@@ -78,10 +78,6 @@ src_prepare() {
multilib_src_configure() {
LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
- # remove magic of library detection
- # bug#438222
- local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
-
# TPM needs to be tested before being enabled
libconf+=( --without-tpm )
@@ -113,9 +109,11 @@ multilib_src_configure() {
$(use_enable tls-heartbeat heartbeat-support) \
$(use_with idn) \
$(use_with pkcs11 p11-kit) \
+ --disable-rpath \
--with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
--without-included-libtasn1 \
- "${libconf[@]}"
+ "${libconf[@]}" \
+ $("${S}/configure" --help | grep -- --with-.*-prefix | sed -e 's/prefix.*/prefix/' -e "s#\$#=${EROOT}/usr#")
}
multilib_src_install_all() {