summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-25 23:00:49 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-25 23:05:09 +0100
commit33074d531e1385e0e569d6b21f084818837bc848 (patch)
tree1c626eab25aba36f3299dd1801d56ab4b5d9e79e
parentdev-ros/rosbag: add missing std_srvs dep, bug #610924 (diff)
downloadgentoo-33074d53.tar.gz
gentoo-33074d53.tar.bz2
gentoo-33074d53.zip
app-office/calligra: Drop marble use flag
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-office/calligra/calligra-2.9.11-r1.ebuild5
-rw-r--r--app-office/calligra/calligra-2.9.11.ebuild9
-rw-r--r--app-office/calligra/metadata.xml1
3 files changed, 6 insertions, 9 deletions
diff --git a/app-office/calligra/calligra-2.9.11-r1.ebuild b/app-office/calligra/calligra-2.9.11-r1.ebuild
index 9fcd32a7a80a..b18093c2d145 100644
--- a/app-office/calligra/calligra-2.9.11-r1.ebuild
+++ b/app-office/calligra/calligra-2.9.11-r1.ebuild
@@ -41,7 +41,7 @@ if [[ ${KDE_BUILD_TYPE} == release ]] ; then
fi
IUSE="color-management +crypt +eigen +exif fftw +fontconfig freetds +glew +glib
-+gsf gsl import-filter +jpeg jpeg2k +kdcraw +lcms marble mysql +okular openexr
++gsf gsl import-filter +jpeg jpeg2k +kdcraw +lcms mysql +okular openexr
+pdf +pim postgres spacenav sybase test tiff +threads +truetype vc xbase +xml"
# Don't use Active, it's broken on desktops.
@@ -95,7 +95,6 @@ RDEPEND="
media-libs/lcms:2
x11-libs/libX11
)
- marble? ( $(add_kdeapps_dep marble) )
mysql? ( virtual/mysql )
okular? ( kde-apps/okular:4=[aqua=] )
openexr? ( media-libs/openexr:= )
@@ -177,6 +176,7 @@ src_configure() {
-DPACKAGERS_BUILD=OFF
-DWITH_Soprano=OFF
-DWITH_KActivities=OFF
+ -DWITH_CalligraMarble=OFF
-DWITH_Iconv=ON
-DWITH_OCIO=$(usex color-management)
-DWITH_QCA2=$(usex crypt)
@@ -198,7 +198,6 @@ src_configure() {
-DWITH_OpenJPEG=$(usex jpeg2k)
-DWITH_Kdcraw=$(usex kdcraw)
-DWITH_LCMS2=$(usex lcms)
- -DWITH_CalligraMarble=$(usex marble)
-DWITH_MySQL=$(usex mysql)
-DWITH_Okular=$(usex okular)
-DWITH_OpenEXR=$(usex openexr)
diff --git a/app-office/calligra/calligra-2.9.11.ebuild b/app-office/calligra/calligra-2.9.11.ebuild
index 361b71f6cbf8..f48bdda5b622 100644
--- a/app-office/calligra/calligra-2.9.11.ebuild
+++ b/app-office/calligra/calligra-2.9.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -41,7 +41,7 @@ if [[ ${KDE_BUILD_TYPE} == release ]] ; then
fi
IUSE="attica color-management +crypt +eigen +exif fftw +fontconfig freetds
-+glew +glib +gsf gsl import-filter +jpeg jpeg2k +kdcraw +lcms marble mysql
++glew +glib +gsf gsl import-filter +jpeg jpeg2k +kdcraw +lcms mysql
+okular openexr +pdf +pim postgres spacenav sybase test tiff +threads
+truetype vc xbase +xml"
@@ -97,7 +97,6 @@ RDEPEND="
media-libs/lcms:2
x11-libs/libX11
)
- marble? ( $(add_kdeapps_dep marble) )
mysql? ( virtual/mysql )
okular? ( >=kde-apps/okular-4.4:4=[aqua=] )
opengl? (
@@ -181,7 +180,8 @@ src_configure() {
"-DCREATIVEONLY=OFF"
"-DPACKAGERS_BUILD=OFF"
"-DWITH_Soprano=OFF"
- "-DWITH_KActivities=OFF" # deprecated Plasma 4 activities integration
+ "-DWITH_KActivities=OFF"
+ "-DWITH_CalligraMarble=OFF"
)
# regular options
@@ -207,7 +207,6 @@ src_configure() {
$(cmake-utils_use_with jpeg2k OpenJPEG)
$(cmake-utils_use_with kdcraw Kdcraw)
$(cmake-utils_use_with lcms LCMS2)
- $(cmake-utils_use_with marble CalligraMarble)
$(cmake-utils_use_with mysql MySQL)
$(cmake-utils_use_with okular Okular)
$(cmake-utils_use_with openexr OpenEXR)
diff --git a/app-office/calligra/metadata.xml b/app-office/calligra/metadata.xml
index 9c760ee45473..c3442894b6cf 100644
--- a/app-office/calligra/metadata.xml
+++ b/app-office/calligra/metadata.xml
@@ -20,7 +20,6 @@
<flag name="import-filter">Enable support for various import filter file formats like WordPerfect, Visio and Apple Keynote</flag>
<flag name="kdcraw">Enable support for KDE image manipulating interface via <pkg>kde-apps/libkdcraw</pkg></flag>
<flag name="lcms">Build colorengine plugins using <pkg>media-libs/lcms</pkg></flag>
- <flag name="marble">Enable displaying of maps using Marble</flag>
<flag name="okular">Enable bindings for <pkg>kde-apps/okular</pkg></flag>
<flag name="phonon">Build stage/eventplugins and videoshape plugin using <pkg>media-libs/phonon</pkg></flag>
<flag name="pim">Enable support for KDE PIM resources integration</flag>