summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-11 09:33:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-11 09:40:47 +0100
commit330834d27b1f665c03ea96991f1760374dacdab0 (patch)
treeb01ed598017f4df650562fb06232fd3406f12f28
parentdev-python/jaraco-text: Bump to 3.5.0 (diff)
downloadgentoo-330834d2.tar.gz
gentoo-330834d2.tar.bz2
gentoo-330834d2.zip
dev-python/jaraco-collections: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 60dae7e2fbd7..e63b1313bb06 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.collections-3.0.0.tar.gz 16439 BLAKE2B ff3690d85d91da8d88945e9ab8d16d13c7d0f67a9334f706701f9b392d8cffdd9450b2d6051a92799564cfc81310e45f50368ab729a0b68c08a9c8b0ccd9627d SHA512 c6c5d28fe4b3940c81c68bf877249805db3f508d83a0071947c7a5596d3636631df91cc6e87802b0fa6cd5c8bdd1ef2f39b924471666b44d2147cb64ad1533ad
DIST jaraco.collections-3.1.0.tar.gz 18206 BLAKE2B c420b3c65c048840f2957ebff0e69a7e2d3db515801a54d829bc2dd9f77b804066ef15766c915b764a148eaa945fc9a30576bb00a645f4c124c031b6ccc64184 SHA512 9a3e4e60cd497ee2ed4a092bd823ecffe0d20293dd9ba491fd2c4e5df2481042efa8ba52503b001e11908982608852a0588cd70b4957d0551c066be97389652c
+DIST jaraco.collections-3.2.0.tar.gz 18195 BLAKE2B 51510dd5053563319eac1c412deadac0a5f99ce3144d44150b5835ab92a05529998676fdcb577a5e725b19b4953c47c662e2f3eaa791de955c2493014713dd11 SHA512 cfea2de312781ec9d7a51752570432ec85e62834d02582023378ce0815e0c25f4d4e6afad8486559aa4e3f6fa6e602df917fdb11ed7a72423bea7ae816675258
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.2.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.2.0.ebuild
new file mode 100644
index 000000000000..337b892d43db
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/jaraco-collections-3.0.0-pypy.patch"
+)
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest