summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-07 21:43:58 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-07 22:49:21 +0100
commit330dda170ba8703240a2dd81e2c4d9769f465609 (patch)
tree2d0e120c1bd549d889c46d49d3d09ab643c01f71
parentapp-emacs/consult: drop old 0.29 (diff)
downloadgentoo-330dda17.tar.gz
gentoo-330dda17.tar.bz2
gentoo-330dda17.zip
app-emacs/consult: bump to 0.32
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-0.32.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 15b76c1c2a63..f7ab4ea1b8b3 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1,2 +1,3 @@
DIST consult-0.30.tar.gz 97691 BLAKE2B 3e09bf24a1385f70b77d072c58e5d63a7a3bf3f89e7c2a22751e5dabead62b759c6a52577660c65a17134e0c0dc8f2ea63c79cfb874df4de06556ac2af995a8d SHA512 2eff338c557d096b4bf048d1abcfde093cd600350ce691c33408f15fdf112738eb9aee33c043412b87d7a81d27c939860ea82e5ca55f32382afecded1668934b
DIST consult-0.31.tar.gz 97789 BLAKE2B 800b3afd159e61e39860df8b259b9c3ae7db75094318e879a283bab0ad24b6fd8fa8e42480a0a6f3b036ad8f06cb656759ce9111819dcd9806f0357bd4ee552e SHA512 d38452b8f32ae504099dc80fdf9fe4bdd3c2de5b3f6c4fd065cac9f6f7df1e486d7bae8f8636bd3d6d7dd825c4d8baac992aae9f3948db9584085f6a02dc8ca4
+DIST consult-0.32.tar.gz 101692 BLAKE2B 01c574755345917ea109d4321a31b6720f88bb99d76a26cb5ef90acd7f637734d299708b630971a530ab97eb83d719c634eac6b3481699f4fc94f5a3ea479a72 SHA512 d33c33997542f545d64af9fe9261e1d22b32effaf75fce428903f5d4e50e98f0205976cb000aa0c4ce0218a382171d345d8d806184fbdd63d906fba91d58ab6e
diff --git a/app-emacs/consult/consult-0.32.ebuild b/app-emacs/consult/consult-0.32.ebuild
new file mode 100644
index 000000000000..1a06823ec878
--- /dev/null
+++ b/app-emacs/consult/consult-0.32.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read"
+HOMEPAGE="https://github.com/minad/consult"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-28.1"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}