summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-05 04:33:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-05 04:45:06 +0200
commit332286c42a1c7b95471dcd372ad3f8cd02a971a0 (patch)
treed71754023836b7004b3761aa6c836b9a6749faad
parentdev-python/pipdeptree: Remove old (diff)
downloadgentoo-332286c4.tar.gz
gentoo-332286c4.tar.bz2
gentoo-332286c4.zip
dev-python/lmfit: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lmfit/Manifest1
-rw-r--r--dev-python/lmfit/lmfit-1.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/lmfit/Manifest b/dev-python/lmfit/Manifest
index 551f6cecb01d..2ad85a8f206c 100644
--- a/dev-python/lmfit/Manifest
+++ b/dev-python/lmfit/Manifest
@@ -1 +1,2 @@
DIST lmfit-1.2.2.tar.gz 336346 BLAKE2B 78819c8be935f330b2f0eaad09ff9201c80e12d571571d8ee5088100c4d19a6a78d2e860e7b240fb6f2eea5f27bd0fc72538fdb04e6cc4e3e1d801f4f5fc5110 SHA512 f667bf8eb9c4090beda33de8a32c284a1f1eb2f1643085191943517acf61e125c7bafed37b634267fdc69e49338397248673fc62f8afc8fc8cc6733726cd0313
+DIST lmfit-1.3.0.tar.gz 628754 BLAKE2B e5fa707c8f778227e89c996e4c2763b71562b01e67cbe3558825e2ee278999c5732717953607104ba553faee2984151a978e04c44a624ea95d1bc4fc9f2feb60 SHA512 198b290a8970dc954705824f09b86ee2bd9e12fc71635fe89e38a5911f88103861daab6f292a6e4c93bc3e3413676b33f680cea7adae3137feb251d792f76270
diff --git a/dev-python/lmfit/lmfit-1.3.0.ebuild b/dev-python/lmfit/lmfit-1.3.0.ebuild
new file mode 100644
index 000000000000..93e1d36d7e10
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="
+ https://lmfit.github.io/lmfit-py/
+ https://github.com/lmfit/lmfit-py/
+ https://pypi.org/project/lmfit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asteval-0.9.28[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.6[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}