summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-01-08 16:01:37 +0100
committerSebastian Pipping <sping@gentoo.org>2022-01-08 16:01:37 +0100
commit33289e80e5ad2ce3a26a4cc6f1964df258e0e9ac (patch)
tree50b2285cd51be12c889271a2b39b68c8e6a59783
parentdev-python/uvicorn: Stabilize 0.16.0 ALLARCHES, #830795 (diff)
downloadgentoo-33289e80e5ad2ce3a26a4cc6f1964df258e0e9ac.tar.gz
gentoo-33289e80e5ad2ce3a26a4cc6f1964df258e0e9ac.tar.bz2
gentoo-33289e80e5ad2ce3a26a4cc6f1964df258e0e9ac.zip
dev-libs/uriparser: Drop vulnerable <0.9.6
Bug: https://bugs.gentoo.org/830665 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
-rw-r--r--dev-libs/uriparser/Manifest1
-rw-r--r--dev-libs/uriparser/uriparser-0.9.5.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-libs/uriparser/Manifest b/dev-libs/uriparser/Manifest
index ee86970d1b4..29e0a6b2209 100644
--- a/dev-libs/uriparser/Manifest
+++ b/dev-libs/uriparser/Manifest
@@ -1,2 +1 @@
-DIST uriparser-0.9.5.tar.bz2 176501 BLAKE2B 5ec3d993e60c62f2478e4012354cf82f2e4155ea1a69e9a3d6611d1765fe0f3b8ba5382c928852a5fd215f51ebb0688c9d713e9f1208f18f5ce2d8b8f0fb1dca SHA512 44d36a33565b7724d721e2b5e689530227bc87e609ee78f1d23e7353480191313b1b91039c7a046566d14b83eb320c97d75e74c8ef4841e1b9c8559c3feddb34
DIST uriparser-0.9.6.tar.bz2 178888 BLAKE2B 2c7229d8438eaef40657b809742dff7ed8919edfe9b4003be996d967b2d876ec61c6493b60c3a0a167db80365c748ee63f2cebfa04058ae8bed8d29b0ab7ea22 SHA512 c021ab3f93cc0373c9244edafff042c3d73a3904d69e573c277b04ca4a49cd2e88255214599cf433088b32846c9a628dfb116025188a6bb61a40c236827799aa
diff --git a/dev-libs/uriparser/uriparser-0.9.5.ebuild b/dev-libs/uriparser/uriparser-0.9.5.ebuild
deleted file mode 100644
index 9b07a35769d..00000000000
--- a/dev-libs/uriparser/uriparser-0.9.5.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Strictly RFC 3986 compliant URI parsing library in C"
-HOMEPAGE="https://uriparser.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="+doc qt5 test unicode" # +doc to address warning RequiredUseDefaults
-
-REQUIRED_USE="qt5? ( doc ) test? ( unicode )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? ( >=dev-cpp/gtest-1.8.1 )
-"
-BDEPEND="
- virtual/pkgconfig
- doc? (
- >=app-doc/doxygen-1.5.8
- media-gfx/graphviz
- qt5? ( dev-qt/qthelp:5 )
- )
-"
-
-DOCS=( AUTHORS ChangeLog THANKS )
-
-src_configure() {
- local mycmakeargs=(
- -DURIPARSER_BUILD_CHAR=ON
- -DURIPARSER_BUILD_DOCS=$(usex doc ON OFF)
- -DURIPARSER_BUILD_TESTS=$(usex test ON OFF)
- -DURIPARSER_BUILD_TOOLS=ON
- -DURIPARSER_BUILD_WCHAR_T=$(usex unicode ON OFF)
-
- # The usex wrapper is here to address this warning:
- # One or more CMake variables were not used by the project:
- # CMAKE_DISABLE_FIND_PACKAGE_Qt5Help
- $(usex doc "$(cmake_use_find_package qt5 Qt5Help)")
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use doc && use qt5; then
- dodoc "${BUILD_DIR}"/doc/*.qch
- docompress -x /usr/share/doc/${PF}/${P}.qch
- fi
-}