summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-20 16:51:22 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-20 18:38:01 +0200
commit334a5ba9db9c620e265d3c4848a2e8afa4a3b3d2 (patch)
tree70ec99752ac23d93bb41015a1b132c4cf219f072
parentdev-perl/Crypt-SSLeay: add libressl support (diff)
downloadgentoo-334a5ba9db9c620e265d3c4848a2e8afa4a3b3d2.tar.gz
gentoo-334a5ba9db9c620e265d3c4848a2e8afa4a3b3d2.tar.bz2
gentoo-334a5ba9db9c620e265d3c4848a2e8afa4a3b3d2.zip
net-libs/libssh2: add libressl support
-rw-r--r--net-libs/libssh2/libssh2-1.6.0-r1.ebuild46
-rw-r--r--net-libs/libssh2/libssh2-9999.ebuild8
2 files changed, 52 insertions, 2 deletions
diff --git a/net-libs/libssh2/libssh2-1.6.0-r1.ebuild b/net-libs/libssh2/libssh2-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..631d0ba03cf3
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.6.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+inherit autotools-multilib
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="gcrypt libressl static-libs test zlib"
+
+DEPEND="
+ !gcrypt? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.2-pkgconfig.patch )
+
+src_prepare() {
+ sed -i -e 's|mansyntax.sh||g' tests/Makefile.am || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ # Disable tests that require extra permissions (bug #333319)
+ use test && local -x ac_cv_path_SSHD=
+
+ local myeconfargs=(
+ $(use_with zlib libz)
+ $(usex gcrypt --with-libgcrypt --with-openssl)
+ )
+ autotools-utils_src_configure
+}
diff --git a/net-libs/libssh2/libssh2-9999.ebuild b/net-libs/libssh2/libssh2-9999.ebuild
index a41ca40951fa..8d3718bc0833 100644
--- a/net-libs/libssh2/libssh2-9999.ebuild
+++ b/net-libs/libssh2/libssh2-9999.ebuild
@@ -15,9 +15,13 @@ SRC_URI=""
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="gcrypt static-libs test zlib"
+IUSE="gcrypt libressl static-libs test zlib"
-DEPEND="!gcrypt? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+DEPEND="
+ !gcrypt? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"