summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-09 07:10:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-09 07:28:16 +0100
commit334bdce14993573d1819dd509eddf98b03770e03 (patch)
tree2002f322cc392b5a5a27f5470a91684cbbbfc3e4
parentdev-python/xarray: Bump to 2023.12.0 (diff)
downloadgentoo-334bdce14993573d1819dd509eddf98b03770e03.tar.gz
gentoo-334bdce14993573d1819dd509eddf98b03770e03.tar.bz2
gentoo-334bdce14993573d1819dd509eddf98b03770e03.zip
dev-python/bandit: Bump to 1.7.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.7.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 7fca10fffcf3..361db296dbb1 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1 +1,2 @@
DIST bandit-1.7.5.tar.gz 1970878 BLAKE2B 45787b6d1ebebb5ce25fa67173095a0e97b6f95992d828530cfade8c7f50d0c7b945884539695426f93cf3ed6a42178e18501768aa32c3b0c7019eb20aa3bc95 SHA512 81b93654ba62e6d22e8c2d534b9f575979bad4f66acd90c221d214316cd1863e7c7e179b8e2a2a8fa80034db71ebda8636adb25b36e1827194bb4639e67ada09
+DIST bandit-1.7.6.tar.gz 1977532 BLAKE2B 2580641ee0e19364d36988ff3757a55bd7ff8c0a3e47d564873940b5f9c1b8335a2eb724c9394ff76e341a766054bec27ef296a9502fec60d96a5eb65a015f4b SHA512 6635704e2e60e23f5d21de345152e13ef1bde5efb92ccc0e6dde46e8405c1e5dd9530830af4d2a3c5d6e0bb0eb106ccce4cde3a7be678cce499486e752a26428
diff --git a/dev-python/bandit/bandit-1.7.6.ebuild b/dev-python/bandit/bandit-1.7.6.ebuild
new file mode 100644
index 000000000000..ffa1485a066a
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="
+ https://github.com/PyCQA/bandit/
+ https://pypi.org/project/bandit/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-3.1.30[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests unittest