summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-22 22:40:46 +0000
committerSam James <sam@gentoo.org>2021-03-23 04:48:47 +0000
commit3352d28301fd2c5b30afbb5726716757530832e1 (patch)
treefd5284b45f153ec6eb67be6b1457e94e9bddef12
parentdev-libs/libmix: whitespace change (diff)
downloadgentoo-3352d28301fd2c5b30afbb5726716757530832e1.tar.gz
gentoo-3352d28301fd2c5b30afbb5726716757530832e1.tar.bz2
gentoo-3352d28301fd2c5b30afbb5726716757530832e1.zip
dev-libs/libsodium: add comment re musl SSP, style
* Add comment re musl SSP (check this is still needed, bug ref) * Style changes including quoting array variable Bug: https://bugs.gentoo.org/747346 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libsodium/libsodium-1.0.18.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-libs/libsodium/libsodium-1.0.18.ebuild b/dev-libs/libsodium/libsodium-1.0.18.ebuild
index 181638171400..220e1a8d1c63 100644
--- a/dev-libs/libsodium/libsodium-1.0.18.ebuild
+++ b/dev-libs/libsodium/libsodium-1.0.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,9 @@ SLOT="0/23"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="+asm minimal static-libs +urandom cpu_flags_x86_sse4_1 cpu_flags_x86_aes"
-PATCHES=( "${FILESDIR}"/${PN}-1.0.10-cpuflags.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.10-cpuflags.patch
+)
src_prepare() {
default
@@ -32,15 +34,17 @@ multilib_src_configure() {
)
# --disable-pie is needed on x86, see bug #512734
- if [[ "${MULTILIB_ABI_FLAG}" == "abi_x86_32" ]]; then
+ if [[ "${MULTILIB_ABI_FLAG}" == "abi_x86_32" ]] ; then
myeconfargs+=( --disable-pie )
+
# --disable-ssp is needed on musl x86
- if use elibc_musl; then
+ # TODO: Check if still needed? bug #747346
+ if use elibc_musl ; then
myeconfargs+=( --disable-ssp )
fi
fi
- ECONF_SOURCE="${S}" econf ${myeconfargs[@]}
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {