summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-11 10:16:32 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-11 10:44:40 +0200
commit33542c06f4670a52f111cf4f3c3a99b1c23b4e03 (patch)
treeb9ad8ff096c8f0598bcc282142a7b99bcebab5ed
parentnet-dns/knot: Bump to 3.2.1 (diff)
downloadgentoo-33542c06f4670a52f111cf4f3c3a99b1c23b4e03.tar.gz
gentoo-33542c06f4670a52f111cf4f3c3a99b1c23b4e03.tar.bz2
gentoo-33542c06f4670a52f111cf4f3c3a99b1c23b4e03.zip
dev-python/oslo-concurrency: Bump 5.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-5.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index f44c8b0de32d..54e03932feeb 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1,2 @@
DIST oslo.concurrency-5.0.0.tar.gz 59343 BLAKE2B 412fba38e0281b2c6d7b27182d159c99730a22ec3400586481f234998cd2f446de5cdd84aaa3abb1cdd93eb9eff1294c87ce51e165dc49caa078e69932ecd19b SHA512 570acbaf599a8a177ba6bc7c009edb43db5e077c06bee5c5895d81944daf78c8dde197bd9af730b17b5075fdaf527252aa44ea0edb79d73e16714582645afb7e
+DIST oslo.concurrency-5.0.1.tar.gz 59944 BLAKE2B 76962f187d58c514f7465a5cac2e695ee83ca020ae0f9d0d0d5a8e27cfcfb6d008f2df97f8b353ef2e7c57562b2cd169a4f6ccfb16bdaefcce1ace81445a64a7 SHA512 5987900e71020b2b8b77eac69c3541647c1600cb8a51f02d45938367e45ddce5e71b874a1eda79aadfec51d639fdb895f056964d0b4bd9bba597ae9423f35463
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-5.0.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-5.0.1.ebuild
new file mode 100644
index 000000000000..ab3fd501a07b
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-5.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.concurrency/
+ https://github.com/openstack/oslo.concurrency/
+ https://pypi.org/project/oslo.concurrency/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails, then hangs
+ rm oslo_concurrency/tests/unit/test_lockutils_eventlet.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}