summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 02:04:58 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:37:02 -0400
commit335aa76dfa7ee372bd022d4d18f5b625b1277a18 (patch)
treee7c69b17eed263b1294578784b8ee1333d01e619
parentgames-board/xmille: force gcc -E for imake's generation (diff)
downloadgentoo-335aa76dfa7ee372bd022d4d18f5b625b1277a18.tar.gz
gentoo-335aa76dfa7ee372bd022d4d18f5b625b1277a18.tar.bz2
gentoo-335aa76dfa7ee372bd022d4d18f5b625b1277a18.zip
games-board/xscrabble: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. wrt #870793 this gets further but still many implicit declaration issues with clang16. Bug: https://bugs.gentoo.org/870793 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-board/xscrabble/xscrabble-2.10-r4.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/games-board/xscrabble/xscrabble-2.10-r4.ebuild b/games-board/xscrabble/xscrabble-2.10-r4.ebuild
index 89303a0e6ce2..d8a308d70fe6 100644
--- a/games-board/xscrabble/xscrabble-2.10-r4.ebuild
+++ b/games-board/xscrabble/xscrabble-2.10-r4.ebuild
@@ -23,6 +23,7 @@ RDEPEND="
!<x11-terms/kterm-6.2.0-r7
"
BDEPEND="
+ sys-devel/gcc
x11-misc/gccmakedep
>=x11-misc/imake-1.0.8-r1
"
@@ -56,7 +57,7 @@ src_configure() {
filter-lto
tc-export AR CC LD RANLIB
- export IMAKECPP=${IMAKECPP:-$(tc-getCPP)}
+ export IMAKECPP=${IMAKECPP:-${CHOST}-gcc -E}
}
src_compile() {