summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-05-11 09:25:36 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-05-11 09:55:27 +0300
commit33777f0268bb4fa2bcf9687472cd038371365844 (patch)
tree17120b5a244fd564e34a8565d6a5bae35c4a9677
parentsys-process/evisum: bump to 0.4.1 (diff)
downloadgentoo-33777f0268bb4fa2bcf9687472cd038371365844.tar.gz
gentoo-33777f0268bb4fa2bcf9687472cd038371365844.tar.bz2
gentoo-33777f0268bb4fa2bcf9687472cd038371365844.zip
x11-terms/terminology: bump to 1.7.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/terminology-1.7.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 71f4508bc272..6148880a42ca 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1 +1,2 @@
DIST terminology-1.6.0.tar.xz 4893348 BLAKE2B 20c9b8a916a4cd48055839266a157d5d8fca70557f7fb8b61696ceeaf4bc0fd93ea5abc0930d1c552a816e3fa3e455624f62d4adbad7feacc9cd0e874a91feec SHA512 ef95a5d128736a2e6b3b9e48a3f32a8e3a1f19ccabcb9fa429ed777ee201ba16fa431a61edafaebc018567f4a3657d81551407cf0449f58b416aa1e6077afec1
+DIST terminology-1.7.0.tar.xz 4922616 BLAKE2B 40ca7bfff534e773b4c188970ecd82e44c2eee7a75eb2a6d4fc6a8635c57857e2037a319818a437843271faa42995f25b613091a4463c02427d835c6ae572722 SHA512 9635da6a51344fbbafd333592252c2539daa795600b4a1d5ea5710e294f18ff9f5667706c789a3c91378b493ae631df47faec2bc43b4cc48d0266506ab3f2e78
diff --git a/x11-terms/terminology/terminology-1.7.0.ebuild b/x11-terms/terminology/terminology-1.7.0.ebuild
new file mode 100644
index 000000000000..1e62124d474c
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[gles2] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}