summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-16 14:51:37 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-16 16:47:34 +0200
commit338be244f82c5998e8d4e185c6342965589fbca7 (patch)
tree861432b743d3b328ee828676fae965ad3ac3f8cb
parentgames-util/cartridges: drop old 2.0.4 (diff)
downloadgentoo-338be244f82c5998e8d4e185c6342965589fbca7.tar.gz
gentoo-338be244f82c5998e8d4e185c6342965589fbca7.tar.bz2
gentoo-338be244f82c5998e8d4e185c6342965589fbca7.zip
games-util/cartridges: bump to 2.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-util/cartridges/Manifest1
-rw-r--r--games-util/cartridges/cartridges-2.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/games-util/cartridges/Manifest b/games-util/cartridges/Manifest
index 928d9d9de4a1..f9f50ed841e3 100644
--- a/games-util/cartridges/Manifest
+++ b/games-util/cartridges/Manifest
@@ -1,2 +1,3 @@
DIST cartridges-2.1.1.tar.gz 1337163 BLAKE2B 6d4a67d8d6ecc035e6b3b12a7d5c9160de2af46423264c670bb7e448d00393a6dc7742ab30047eaa888689d9ad0eb5baf9657523164761cff3b71d4b23a9d551 SHA512 0963e2e5183a8cbb8c1de1fbbf9f67beda65eb7396aaf644fcc30ed79a3dd8136e5e78d3a5b065c9b6f2a4cba4e3c715e412f1cc651a555195d9af5cc6f1e22b
DIST cartridges-2.2.1.tar.gz 1277149 BLAKE2B 5295253e8347254905b7911a8fc9bab44b953dbed90a9d7211eef651317bd38e6d04a7218cb4c418a7af5223bc53789e866c688cc85239b922d54722a9c055bc SHA512 f2e0ed8ef9f916cf0cdf1e1134286d1242948291b24cf6103c2171a232c97c05c3260aeb307f6cfaee6d78a473151440f2e0854bcb1ccaf1f854952b8a50a2c6
+DIST cartridges-2.3.tar.gz 1282083 BLAKE2B 1e6ef65ba223af5b65af922c90b61b5c1bca1859b4231632b2c2996258f562719340f7cb9c6facc6f8151bac8388bcfe3c549131bee9b249d0d03310a622538b SHA512 d5f2d29414d1e347e0459003890f018e585450cc3b6663e922696f04c1eff3a864364a08dfa17ea6fe4e87aa47c28485f0954a4376c1d1695039e478a7dbe7f4
diff --git a/games-util/cartridges/cartridges-2.3.ebuild b/games-util/cartridges/cartridges-2.3.ebuild
new file mode 100644
index 000000000000..05c8ac27f772
--- /dev/null
+++ b/games-util/cartridges/cartridges-2.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Simple game launcher written in Python using GTK4 and Libadwaita"
+HOMEPAGE="https://github.com/kra-mo/cartridges/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kra-mo/${PN}.git"
+else
+ SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.4-dont-validate-appstream.patch )
+
+src_install() {
+ meson_src_install
+
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize "${ED}"/usr/share/cartridges/cartridges
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}