summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 15:15:56 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 15:15:56 +0200
commit33937f23c9c109caeb28da7d5f968808ef1c063c (patch)
tree62e6b565d546910fdcc00ed3ec12475e73729f79
parentsys-fs/multipath-tools: add 0.9.0 (diff)
downloadgentoo-33937f23c9c109caeb28da7d5f968808ef1c063c.tar.gz
gentoo-33937f23c9c109caeb28da7d5f968808ef1c063c.tar.bz2
gentoo-33937f23c9c109caeb28da7d5f968808ef1c063c.zip
net-libs/rpc2: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/716076 Closes: https://bugs.gentoo.org/725048 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-libs/rpc2/files/rpc2-2.14-include.patch10
-rw-r--r--net-libs/rpc2/files/rpc2-2.14-respect-flags.patch21
-rw-r--r--net-libs/rpc2/rpc2-2.14-r1.ebuild (renamed from net-libs/rpc2/rpc2-2.14.ebuild)14
3 files changed, 38 insertions, 7 deletions
diff --git a/net-libs/rpc2/files/rpc2-2.14-include.patch b/net-libs/rpc2/files/rpc2-2.14-include.patch
new file mode 100644
index 000000000000..248604654427
--- /dev/null
+++ b/net-libs/rpc2/files/rpc2-2.14-include.patch
@@ -0,0 +1,10 @@
+--- a/rpc2-src/rpc2b.c
++++ b/rpc2-src/rpc2b.c
+@@ -42,6 +42,7 @@
+ #include <config.h>
+ #endif
+
++#include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
diff --git a/net-libs/rpc2/files/rpc2-2.14-respect-flags.patch b/net-libs/rpc2/files/rpc2-2.14-respect-flags.patch
new file mode 100644
index 000000000000..e93e08ab6a4c
--- /dev/null
+++ b/net-libs/rpc2/files/rpc2-2.14-respect-flags.patch
@@ -0,0 +1,21 @@
+--- a/rp2gen/Makefile.in
++++ b/rp2gen/Makefile.in
+@@ -198,7 +198,8 @@
+ CCDEPMODE = @CCDEPMODE@
+
+ # override any cross compilation target flags
+-CFLAGS = -Wall
++AM_CFLAGS = -Wall
++CFLAGS = @CFLAGS@
+ CONFIG_DATE = @CONFIG_DATE@
+ CP = @CP@
+ CPP = @CPP@
+@@ -225,7 +226,7 @@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LD = @LD@
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+ LEX = @LEX@
+ LEXLIB = @LEXLIB@
+ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
diff --git a/net-libs/rpc2/rpc2-2.14.ebuild b/net-libs/rpc2/rpc2-2.14-r1.ebuild
index 8a998507de08..6e2f4af36aa0 100644
--- a/net-libs/rpc2/rpc2-2.14.ebuild
+++ b/net-libs/rpc2/rpc2-2.14-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Remote procedure call package for IP/UDP (used by Coda)"
HOMEPAGE="http://www.coda.cs.cmu.edu/"
@@ -10,17 +10,17 @@ SRC_URI="http://www.coda.cs.cmu.edu/pub/rpc2/src/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="1"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc x86"
-IUSE="static-libs"
RDEPEND=">=sys-libs/lwp-2.5"
DEPEND="${RDEPEND}"
-src_configure() {
- econf $(use_enable static-libs static)
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+ "${FILESDIR}"/${P}-include.patch
+)
src_install() {
default
- dodoc README.ipv6
- use static-libs || find "${ED}"/usr -name '*.la' -delete
+
+ find "${ED}" -type f -name '*.la' -delete || die
}