summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-25 09:19:30 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-25 09:21:12 +0100
commit3398f450d0da14ff4fc96143676db651594bb99c (patch)
treef1acde44cc0120ac7046166d996a059e43a02627
parentdev-python/iminuit: Add python@ as co-maint (diff)
downloadgentoo-3398f450d0da14ff4fc96143676db651594bb99c.tar.gz
gentoo-3398f450d0da14ff4fc96143676db651594bb99c.tar.bz2
gentoo-3398f450d0da14ff4fc96143676db651594bb99c.zip
dev-python/llfuse: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.4.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index 19a139722185..10b53ddefdf9 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1 +1,2 @@
DIST llfuse-1.3.6.tar.bz2 361750 BLAKE2B 74387a6aeb28c3f49234a4f430c3f2aaeefa2057d69e681405d9588c63b3a6e4a6daa58b8996541825c73ff4dabc5607874c2d7885586d793a6436e3f680aec2 SHA512 d67e39daf65c92ebb5bf69abb0c5dc3a88460228b5ec5ee762a11fc909369562411297e8ff9f512ee1ef539d8abec765924be581703fb7e99963c6512cb1f0bd
+DIST llfuse-1.4.0.tar.gz 478758 BLAKE2B bec4d6b53936bc79ab4ca8fce7b34d60e39aff6128a186d58caeac68ad135d7d29bbd667cf669e065256e31e257ff4516ff967759d6152672659df0062d03e6d SHA512 8ab92912279a478ba50cf0c151cce3ce1125de27922a97c4da4b3af4ff0714e3a2c5a9e6fd10b87653eb552509491084f018ae3ce4feb7bf952de00a5be3eccc
diff --git a/dev-python/llfuse/llfuse-1.4.0.ebuild b/dev-python/llfuse/llfuse-1.4.0.ebuild
new file mode 100644
index 000000000000..bc330b795374
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://github.com/python-llfuse/python-llfuse/ https://pypi.org/project/llfuse/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=sys-fs/fuse-2.8.0:0
+"
+DEPEND="
+ sys-apps/attr
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/llfuse-1.3.5-cflags.patch
+)
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}