summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 23:34:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 23:58:45 +0200
commit33e9e664749ca26aca65989646c81e23259001cf (patch)
treec64bb81a8b5af07470dd7145af9b325bb4e70bbb
parentdev-python/Rx: Add python@ as co-maint. (diff)
downloadgentoo-33e9e664.tar.gz
gentoo-33e9e664.tar.bz2
gentoo-33e9e664.zip
dev-python/arpeggio: Bump to 1.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/arpeggio/Manifest1
-rw-r--r--dev-python/arpeggio/arpeggio-1.10.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/arpeggio/Manifest b/dev-python/arpeggio/Manifest
index 69f6b25de0b3..f42a192246b6 100644
--- a/dev-python/arpeggio/Manifest
+++ b/dev-python/arpeggio/Manifest
@@ -1 +1,2 @@
DIST Arpeggio-1.10.0.tar.gz 766416 BLAKE2B 75898c5be536998a12ec0efb8ca0729913e9ac7ac8481f614cb1bfd5332015bd2c22722cc6836511e1b77d933fe497538db1a00804e2cbf409af7cc153ba15c6 SHA512 368c478114ddedbf40c94b4e656945063df5661deacc9c75780ddca18198a9e3e504718fc6c9a1e84c11c5c8f2b454584d1cfc5a14ea2b783e97b8e317047023
+DIST Arpeggio-1.10.2.tar.gz 766747 BLAKE2B 91e828731757b6ca1e16900edca3f45378c5bb05469e1d32571f9185dbb887f5cf6ae54afecf77f352f882d9056a0814c65aabf51424b482ae3a8cb90f11740a SHA512 c6a162f9ab854bac7e2bc9e5d5553c2dbcc068fcf61607149727cd4c8a7c87c63cab765b423c8ea76e09fa81ccc42157d724388a81e22864580ccf734998142a
diff --git a/dev-python/arpeggio/arpeggio-1.10.2.ebuild b/dev-python/arpeggio/arpeggio-1.10.2.ebuild
new file mode 100644
index 000000000000..f11ba62fad56
--- /dev/null
+++ b/dev-python/arpeggio/arpeggio-1.10.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/textX/Arpeggio"
+SRC_URI="https://github.com/textX/Arpeggio/archive/${PV}.tar.gz -> ${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/^setup_requires/,/^[^[:space:]]/d' \
+ -e '/^exclude/a\
+ examples.*' \
+ -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}