summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-01-01 11:47:24 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-01 11:47:24 +0000
commit33f31999cb4307a878dc6138fe5951f107be99d3 (patch)
treef9c4d6b671d2a1746d756177a04cae4050d4a1c6
parentapp-text/xmldiff: stable 2.4 for sparc, bug #762080 (diff)
downloadgentoo-33f31999.tar.gz
gentoo-33f31999.tar.bz2
gentoo-33f31999.zip
dev-util/bustle: bump up to 0.8.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-util/bustle/Manifest1
-rw-r--r--dev-util/bustle/bustle-0.8.0.ebuild67
-rw-r--r--dev-util/bustle/metadata.xml5
3 files changed, 72 insertions, 1 deletions
diff --git a/dev-util/bustle/Manifest b/dev-util/bustle/Manifest
index 03f54b60f84a..0af30f8d5766 100644
--- a/dev-util/bustle/Manifest
+++ b/dev-util/bustle/Manifest
@@ -1 +1,2 @@
DIST bustle-0.5.4.tar.gz 122720 BLAKE2B b5a2315919644ab5c7712f9e9bde1bdea226b4e8898981f7150558bde648a5c7965be6ad8484c09727665292e5fe3f0cb545544dbb27f2a2553e513910289620 SHA512 56eaeef831fb5929d57a008ae71d8409048ce5d12eaada98830ef742baf3479264203465d77591cb338374096eac2dc2b68b44f075b2761f16df63fad54b91fd
+DIST bustle-0.8.0.tar.gz 101175 BLAKE2B 30359a51da16631eda8f74239de7955d5887e12e7e99853dd930b12b351a0dd56425487c339ddf297dae02b271019c11329130aa0caabc4bf0c87e21600b707b SHA512 92f4757c4ed9dd88bfa144a0626d7530b6a1f859a8069d8631a9990b6a523dbb59d573c6ba142614c371171ccf391a3e77d1e8ba0c2155ecf231f9e7aa735f72
diff --git a/dev-util/bustle/bustle-0.8.0.ebuild b/dev-util/bustle/bustle-0.8.0.ebuild
new file mode 100644
index 000000000000..cf60600336ea
--- /dev/null
+++ b/dev-util/bustle/bustle-0.8.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -hgettext
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Draw sequence diagrams of D-Bus traffic"
+HOMEPAGE="https://gitlab.freedesktop.org/bustle/bustle#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="interactivetests +threaded"
+
+RDEPEND="dev-haskell/cairo:=
+ dev-haskell/gio:=
+ dev-haskell/glib:=
+ dev-haskell/gtk3:=
+ >=dev-haskell/mtl-2.2.1:=
+ dev-haskell/pango:=
+ dev-haskell/text:=
+ >=dev-lang/ghc-8.4.3:=
+ dev-libs/glib:2
+ net-libs/libpcap
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ virtual/pkgconfig
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-hgettext \
+ $(cabal_flag interactivetests interactivetests) \
+ $(cabal_flag threaded threaded)
+}
+
+src_compile() {
+ # compile haskell part
+ haskell-cabal_src_compile || die "could not build haskell parts"
+
+ # compile C part
+ emake \
+ "CC=$(tc-getCC)" \
+ "CFLAGS=${CFLAGS}" \
+ "CPPFLAGS=${CPPFLAGS}" \
+ "LDFLAGS=${LDFLAGS}"
+}
+
+src_install() {
+ # install haskell part
+ haskell-cabal_src_install || die "could not install haskell parts"
+
+ dobin "${S}"/dist/build/bustle-pcap
+ doman bustle-pcap.1
+ dodoc README.md NEWS.md
+}
diff --git a/dev-util/bustle/metadata.xml b/dev-util/bustle/metadata.xml
index 00f0a89d7391..0941fe5a2e70 100644
--- a/dev-util/bustle/metadata.xml
+++ b/dev-util/bustle/metadata.xml
@@ -7,6 +7,9 @@
</maintainer>
<use>
<flag name="interactivetests">Build interactive test programs</flag>
- <flag name="threaded">Build with support for multithreaded execution.</flag>
+ <flag name="threaded">Build with the multi-threaded runtime</flag>
</use>
+ <longdescription>
+ Bustle records and draws sequence diagrams of D-Bus activity, showing signal emissions, method calls and their corresponding returns, with timestamps for each individual event and the duration of each method call. This can help you check for unwanted D-Bus traffic, and pinpoint why your D-Bus-based application isn&#39;t performing as well as you like. It also provides statistics like signal frequencies and average method call times.
+ </longdescription>
</pkgmetadata>