summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-02 07:22:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-02 08:37:11 +0100
commit3426b3fbeaeecd66a3ad4cbb46de058a1d6ece80 (patch)
tree6685966fd2853bdf44b44e1255fc8f04bb64bdff
parentdev-games/godot: switch to bundled glslang+vulkan-headers (diff)
downloadgentoo-3426b3fb.tar.gz
gentoo-3426b3fb.tar.bz2
gentoo-3426b3fb.zip
dev-python/cx_Freeze: Bump to 6.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.13.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index 1b9d990fb32c..8d73928cb543 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -1,3 +1,4 @@
DIST cx_Freeze-6.11.1.gh.tar.gz 1307368 BLAKE2B 7bfbe61274b29890ba35fda133d4c18708d3a04bc33c96633f6651fb9712fec4628f92e2044284ad1bfb992a76e4772669a29ada2f12f16741378d636701e4ad SHA512 37586365a901800fcd18ab6e3b0de9e3e9980c8d8b8b61aa1eddf0d01dc50b53cb1ffc77070f5a5ad40c9b7a020b09ced51d38f53688129b2444abe020a75237
DIST cx_Freeze-6.12.0.gh.tar.gz 1483040 BLAKE2B 78faa77b7bd12344f601bcc5811dff43d6e9440f7cf96167b438557f93bc8d26c59c375930090389946005984245ff93232ddb6d7340ca28012ccb356d0ca630 SHA512 a3fdd94b33985b3bb0fbee2fc7438e20f3ddb31f0d71322eed1c06a15954be5845a0b1dfbc55537fe16022db95b446d3fa0b3e8418cd250e653f42a180b8c586
DIST cx_Freeze-6.13.0.gh.tar.gz 1486127 BLAKE2B f0f54db5ce6f0d8d70efc3321741a70d496773742505cf316646051c41154f9f11dba2fc964f6e16d01e2aa54ed2c9988ec006c3bbbf70b1e37f623aee0a061a SHA512 ed6a9607dd93bfe608036beae6f52a535c240fed222d5ae5da43037ef135cd9423e815066539f975facced221d466db5393bb207eadaec3654ed409c664c2f83
+DIST cx_Freeze-6.13.1.gh.tar.gz 1486207 BLAKE2B aa0151fed482714e41a859059f9672950249ad7fe50fa2accaa9d6af7ddc183a8f74d87337f274849a34a404dda0c732300343b58cd872f3bd03bf275c2f4d97 SHA512 48d569fdce5c6cb100232ce3577f0a55a40f3d1dcafa884a4d62af7f27200a21eb892504b47fb7cd106f410354b70d98a8e5245382431bc1f6d990510c77cb36
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.13.1.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.13.1.ebuild
new file mode 100644
index 000000000000..ee713d33b641
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.13.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="
+ https://cx-freeze.readthedocs.io/
+ https://github.com/marcelotduarte/cx_Freeze/
+ https://pypi.org/project/cx-Freeze/
+"
+SRC_URI="
+ https://github.com/marcelotduarte/cx_Freeze/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ virtual/libcrypt:=
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.8.2-buildsystem.patch"
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # new setuptools?
+ tests/test_command_bdist_rpm.py::test_bdist_rpm
+)