summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-09 11:02:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-09 12:39:11 +0100
commit342e5f89b8d4beb31066ec4ec5a765629957e857 (patch)
tree5dde048daf53dc2fa4852c3604f66ce5e95885a3
parentdev-ros/test_rosservice: Bump to 1.13.6. (diff)
downloadgentoo-342e5f89b8d4beb31066ec4ec5a765629957e857.tar.gz
gentoo-342e5f89b8d4beb31066ec4ec5a765629957e857.tar.bz2
gentoo-342e5f89b8d4beb31066ec4ec5a765629957e857.zip
ros-meta/ros_comm: Bump to 1.13.6.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--ros-meta/ros_comm/Manifest1
-rw-r--r--ros-meta/ros_comm/ros_comm-1.13.6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/ros-meta/ros_comm/Manifest b/ros-meta/ros_comm/Manifest
index 0afadfcde6d7..9f21d3814307 100644
--- a/ros-meta/ros_comm/Manifest
+++ b/ros-meta/ros_comm/Manifest
@@ -1,3 +1,4 @@
DIST ros_comm-1.13.2.tar.gz 1007451 BLAKE2B 8963267f7cbe625a1160c3d8bdf34dd9c0b1102612632d8c7af7ac32aba507adb116eb3d33353b6302072fcac6ab312e095b4fdc023ecbe5d6591a2912b6aa82 SHA512 eac7ee469bbdb622bc69e5239dea7e7dc97bec7b7e51a8ee49f18756cba753387e884ccd651e201e01985d23f908828c7ae94c311889557caeb742ddcad2e1b9
DIST ros_comm-1.13.4.tar.gz 1013412 BLAKE2B 0f5a33ae9c5c3bd3c04e26903c4ee7dff2d30f896fbca620100b9db58e8a338cbe79a9305dedb9e8d6f4a9c13b823e5016178db228bb2661eadb6864e20fad40 SHA512 6057afa5b79da661ecdc60459462fe09a7a90b5e43cbf6c5bdfa4095f07e00356eb13c9cab460b91a0c84b789ccf0753c09666ad24fb4b3aec967cb407cf81ce
DIST ros_comm-1.13.5.tar.gz 1027857 BLAKE2B ed2611179bc7f84bf0b9cde1336474a3bc4c3980ebf97241910123abd430a48ae0636a6ddfb6c191bea2905454644c7ec340e26049d8faddca39783bef13d60b SHA512 91af2de897851061eda140d6c96ec88171f1fd1cd7549b6df1ac570e066603c7bb721a58cb19487657387753433d67ad22421408a237d1ffb5ea580c0cf3eeb3
+DIST ros_comm-1.13.6.tar.gz 1047870 BLAKE2B 874e31faa1a6a77292dab4b7fa64ed13a1f1f63f76512ea351e53bd14ce87662cea5c648e48c3c16668104129cc5eb172bc8f381516bdba676c7212f1acbaaf9 SHA512 382e81847141ab95462fc84a8215b945af995d29f9c0d507665e22faaf79aee9789950546ca7737bd40059f3ed1ecd284ff11bd3e6f1732f3c47a433c5d25155
diff --git a/ros-meta/ros_comm/ros_comm-1.13.6.ebuild b/ros-meta/ros_comm/ros_comm-1.13.6.ebuild
new file mode 100644
index 000000000000..7302c050fcff
--- /dev/null
+++ b/ros-meta/ros_comm/ros_comm-1.13.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS communications-related packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+# utilities subdir
+RDEPEND="
+ dev-ros/roslz4
+ dev-ros/xmlrpcpp
+ dev-ros/roswtf
+ dev-ros/message_filters
+"
+# tools subdir
+RDEPEND="${RDEPEND}
+ dev-ros/rosbag
+ dev-ros/rosbag_storage
+ dev-ros/rosconsole
+ dev-ros/rosgraph
+ dev-ros/roslaunch
+ dev-ros/rosmaster
+ dev-ros/rosmsg
+ dev-ros/rosnode
+ dev-ros/rosout
+ dev-ros/rosparam
+ dev-ros/rosservice
+ dev-ros/rostest
+ dev-ros/rostopic
+ dev-ros/topic_tools
+"
+# clients subdir
+RDEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rospy
+"
+# test subdir
+RDEPEND="${RDEPEND}
+ dev-ros/test_rosbag
+ dev-ros/test_rosbag_storage
+ dev-ros/test_roscpp
+ dev-ros/test_rosgraph
+ dev-ros/test_roslaunch
+ dev-ros/test_roslib_comm
+ dev-ros/test_rosmaster
+ dev-ros/test_rosparam
+ dev-ros/test_rospy
+ dev-ros/test_rosservice
+"
+DEPEND="${RDEPEND}"