summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-28 15:06:24 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-28 16:50:54 -0500
commit343a85aae491a6d1429cfd6ae7fe439b11207828 (patch)
tree73b04f56825584cfce0087b39851cc35fabbf6d1
parentdev-python/oslo-reports: 1.22.0 bup (diff)
downloadgentoo-343a85aae491a6d1429cfd6ae7fe439b11207828.tar.gz
gentoo-343a85aae491a6d1429cfd6ae7fe439b11207828.tar.bz2
gentoo-343a85aae491a6d1429cfd6ae7fe439b11207828.zip
dev-python/oslo-rootwrap: 5.9.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/oslo-rootwrap/Manifest1
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.9.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
index f254d86481e0..adc35c181e24 100644
--- a/dev-python/oslo-rootwrap/Manifest
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -1 +1,2 @@
DIST oslo.rootwrap-5.4.1.tar.gz 42202 SHA256 a76cf545515c1cf6d4d9b1a01a339c1356d1eb78ff3b2190e168dafead3c7e7d SHA512 71980ea266703c7880834cf75b69be9f7bee834a3be314f13ade1bb9903ecf6337237a32a1ed06d020c2fdd3807642af1dd676b6736052d4e57784942782d960 WHIRLPOOL 321a2e9774e3702015510d608e4e145d9fc69c4069865dd5215ad6e94e3692e7e56e029298e908fc007f487d54737d3cd4218dfc93d0625c6950edba45da56b2
+DIST oslo.rootwrap-5.9.0.tar.gz 42352 SHA256 f8947b42d02ae26942f0c1166b410016c7e1796b00f00983f685e9eccb91ba91 SHA512 5c299b8701d308f0f02a8edde08d56145781dfe9d25f4b064b2ce926e38a0be5a5dab20d6d57ebaf289af2758d97b81089407e1851edaca23c36436abf8433fd WHIRLPOOL 94ada80d8cf286fd20786106f37ac3579d387157a8125bd74f819b3fbccb31cbd5a00117507e836609c5dcaa64ce6983cd179aa8cd82333fdffeac7f0ddc3d5b
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.9.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.9.0.ebuild
new file mode 100644
index 000000000000..30c95fc65be7
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.9.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}