summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-26 08:15:52 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-26 08:16:08 +0200
commit344d488dfd571c84b53f19e56854a36f69a67e1f (patch)
treef28d6c482dc1822b83f7adc90bcfa1437afb1f14
parentapp-emacs/nxml-gentoo-schemas: drop 20220524 (diff)
downloadgentoo-344d488dfd571c84b53f19e56854a36f69a67e1f.tar.gz
gentoo-344d488dfd571c84b53f19e56854a36f69a67e1f.tar.bz2
gentoo-344d488dfd571c84b53f19e56854a36f69a67e1f.zip
dev-ruby/http-cookie: add 1.0.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/http-cookie/Manifest1
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/Manifest b/dev-ruby/http-cookie/Manifest
index 5bfe6ed058b7..5320eba7327c 100644
--- a/dev-ruby/http-cookie/Manifest
+++ b/dev-ruby/http-cookie/Manifest
@@ -1 +1,2 @@
DIST http-cookie-1.0.4.gem 39424 BLAKE2B 06ac0e667340ac17827a8eb4ed320efe77ad97509fcd444f7e77d887a77643a6b34e84486db78eba52245891d1719e750d9a446c40a4ab7804f2304b600029bd SHA512 788fdaa642e6b596e7a91c57a7942a832c09a84fed88b30fdd8e5a8ad66d72780afc1246e6c83c4dfd5af8018c278750866dd05d804aef793aa067b09519af8d
+DIST http-cookie-1.0.5.gem 39424 BLAKE2B 569a0d18c962be378f3974b400ddf2289c72490b2b93619fcd83ed6c00bbf5def76239c52163dc6231060792abf3a19988285a6cd28f158ff7339252da912e61 SHA512 d530d64b5c2fc3757a6de03384fe768317e24a523d4a4215f5bcc6b5bca9e7b94eeaad1e52fbb67548396b7b2ca7c9d8b68ea7b99109e24770fcf34c950469ef
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.5.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.5.ebuild
new file mode 100644
index 000000000000..45bf95e150ef
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}