summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-19 07:24:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-19 08:02:34 +0200
commit34509506742dbc21d50fd1df36dcba43f0815b4b (patch)
tree663f8105ca3470526bb4102b4e913be5814f3e65
parentdev-python/aiosmtpd: Bump to 1.4.6 (diff)
downloadgentoo-34509506742dbc21d50fd1df36dcba43f0815b4b.tar.gz
gentoo-34509506742dbc21d50fd1df36dcba43f0815b4b.tar.bz2
gentoo-34509506742dbc21d50fd1df36dcba43f0815b4b.zip
dev-python/trimesh: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.4.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 1dd4b7c267f6..efe5f6e4d749 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1 +1,2 @@
DIST trimesh-4.3.2.gh.tar.gz 13597959 BLAKE2B 538c3ecc9153bbef04fd004076277d50e1ac80e73231ae5faffadb6a810e5c6aa23953206f8a9817a16c3d104d0a38b0da07fc6f8460f2bfde0a356c760048d7 SHA512 2bf40f2290875547dabf40101004581e7287cf2a954d4c1bd0df1adbf044e72bd30d8fbbadb8db44e8bfc33049cc68a075b347eeb538f8fef5225a724a4ddc3b
+DIST trimesh-4.4.0.gh.tar.gz 13599198 BLAKE2B 41fe6d8797bca600ef4526420b9a4bc3fe722adff3a6154625801b2e9a8645ad573f4f62926cd00763899d049660145d6e5614316fcfe3c4f4b76c59d59467ba SHA512 227f3da9e42bd2a872d312d5128d7ae169fcee8ef5566e533812fc6222fe6e5dc40c7802a5a7f1bbb583c700e6c8d1017ee1c6a946284e64679f3a138f31da6e
diff --git a/dev-python/trimesh/trimesh-4.4.0.ebuild b/dev-python/trimesh/trimesh-4.4.0.ebuild
new file mode 100644
index 000000000000..90df68a2c9dc
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.4.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}