summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-16 19:26:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-16 19:38:18 -0600
commit34526a9913575954706b8d8ebee25b6f8131cbed (patch)
treeabee8952dda0035f47bedd7e57f094dda201ae7d
parentdev-python/stestr: 1.1.0 add for queens (diff)
downloadgentoo-34526a9913575954706b8d8ebee25b6f8131cbed.tar.gz
gentoo-34526a9913575954706b8d8ebee25b6f8131cbed.tar.bz2
gentoo-34526a9913575954706b8d8ebee25b6f8131cbed.zip
dev-python/os-testr: 1.0.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/os-testr/Manifest1
-rw-r--r--dev-python/os-testr/os-testr-1.0.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/os-testr/Manifest b/dev-python/os-testr/Manifest
index 3043afa51ac4..00cdb773c2a8 100644
--- a/dev-python/os-testr/Manifest
+++ b/dev-python/os-testr/Manifest
@@ -1 +1,2 @@
DIST os-testr-0.8.0.tar.gz 42102 BLAKE2B 030ee587bc6465e414f09d177abd4f75d869da7e8339e1b396da31165212cec221d156b4cb095b1466b19f8baf2dc01087559b1d6b73fbfbfd41dced3df033c1 SHA512 62b5fbb859c1a3b44bc0d57cf4b2cd0a5e6eeff540f5507efd079a73e0f9ee70813e47537b456f1bc600c87da55d05fd23aee0c215b8558cc0b5e71a55950af4
+DIST os-testr-1.0.0.tar.gz 43382 BLAKE2B c5a9b22700ce40acff8ceeb796d9fa0b840038cd285d80630b16c3399e8c188d87dc54de653d06a2c0918185e9ffd4695747f59d4d42eb158f9ea18bc361963d SHA512 2189abc76840d935d63635874ebdae7c325b392bc24a52e07e1046b47a17be6fd97ba17dc5593ae7a1e2bff9c5b0dbbfd8ade8a2382dce2223ee4047b3483cec
diff --git a/dev-python/os-testr/os-testr-1.0.0.ebuild b/dev-python/os-testr/os-testr-1.0.0.ebuild
new file mode 100644
index 000000000000..a5a6ce424f55
--- /dev/null
+++ b/dev-python/os-testr/os-testr-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A testr wrapper to provide functionality for OpenStack projects"
+HOMEPAGE="https://pypi.python.org/pypi/os-testr https://github.com/openstack/os-testr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}