summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-16 07:16:34 +0000
committerSam James <sam@gentoo.org>2022-12-16 07:16:40 +0000
commit34564839cadebb24c14385ce59055d7c5ead97c2 (patch)
treeeb9480b2cdc2a54e8268f8c542c8012ceb4a0df6
parentdev-libs/gmp: switch to HTTPS for SRC_URI (diff)
downloadgentoo-34564839.tar.gz
gentoo-34564839.tar.bz2
gentoo-34564839.zip
media-gfx/pngcheck: add 3.0.3
Bug: https://bugs.gentoo.org/866233 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/pngcheck/Manifest1
-rw-r--r--media-gfx/pngcheck/pngcheck-3.0.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/pngcheck/Manifest b/media-gfx/pngcheck/Manifest
index 38a9de56965b..092cb82f13c5 100644
--- a/media-gfx/pngcheck/Manifest
+++ b/media-gfx/pngcheck/Manifest
@@ -1 +1,2 @@
DIST pngcheck-3.0.2.tar.gz 63202 BLAKE2B 4cc6040e087aa2f5829e79ea1a5feb45af8bb15fa72325f9cb4822169c7d278306d6d89b936fd4c3c3819a09380e07f1f64ce0c276e776c3146c1533b1ee1363 SHA512 81bba699141c0f506ee589785eccc4b1ea882df5d211bcd91885bbcc4230bf14d23fc1298ffc10a110d6a8459522f6a01bfba1f81739f6085e4d3de964bda3d5
+DIST pngcheck-3.0.3.tar.gz 63766 BLAKE2B 962f90e6a05170a14fba45372d65f8cc94d1b4f6119c30d252a67644b69eb8a925c20b0d020b917673754f491305f73ac7e294df9b2a908a93011cec420c3629 SHA512 cdb2620cb508f9df748bd3e9cb657d2c503a1f62171f497f1ff1e0f220287364829f03164869567c83b5797d8bc478495ad6c35860196812ef8262fce4cbff26
diff --git a/media-gfx/pngcheck/pngcheck-3.0.3.ebuild b/media-gfx/pngcheck/pngcheck-3.0.3.ebuild
new file mode 100644
index 000000000000..536c33d0495d
--- /dev/null
+++ b/media-gfx/pngcheck/pngcheck-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Verifies the integrity of PNG, JNG, and MNG files with internal checksums"
+HOMEPAGE="http://www.libpng.org/pub/png/apps/pngcheck.html"
+SRC_URI="http://www.libpng.org/pub/png/src/${P}.tar.gz"
+
+LICENSE="HPND GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -f Makefile.unx \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -DUSE_ZLIB" \
+ ZLIB="-lz"
+}
+
+src_install() {
+ dobin png{check,split,-fix-IDAT-windowsize}
+ doman pngcheck.1 gpl/pngsplit.1
+
+ einstalldocs
+}